Graphing(ベータ版)のBioRender Graphingエージェントの使い方 Graphing(ベータ版)のBioRender Graphingエージェントの使い方

Graphing(ベータ版)のBioRender Graphingエージェントの使い方

BioRenderのGraphingエージェントは、グラフの作成と分析をサポートする組み込みアシスタントです。手動で設定する代わりに、調べたい内容を自然な言葉で説明すると、Graphingエージェントが元のデータから直接グラフを作成します。Graphingエージェントは現在ベータ版であることにご注意ください。 

Graphingエージェント(ベータ版)を試す  

この記事では、次の内容について説明します。

Graphingエージェントを使用できるユーザー

GraphingエージェントはBioRender Graphingの一部で、追加料金なしで利用できます。まだGraphingのシートをお持ちでない場合は、BioRender Graphing:プランと料金をご覧ください。

Graphingエージェントでできること

  • データを追加する:スプレッドシートのアップロードを案内し、ファイル内のデータセットを見つけて、変数を検出します。
  • データを説明する:インポート後、細胞株全体の濃度測定値を含むELISAプレートのデータセットなど、データセット内で確認できる内容を説明します。
  • グラフを提案・作成する:データに適したグラフの種類を推奨し、変数を割り当て、グループ化のオプションを提示して、グラフを作成します。
  • Run分析を実行する:グラフで利用可能な分析を一覧表示し、1つを推奨して、設定をサポートします。
  • グラフをカスタマイズする:色、ラベル、軸、データポイントのスタイルなど、変更したい内容を説明すると、エージェントが適用します。
  • 次のステップを提案する:各ステップの後に、細胞株を比較するための分析の適合など、次に行う操作を提案します。
  • タブ間でサポートする:エージェントはData、Graph、Analysisタブで利用でき、タブを切り替えても会話とデータのコンテキストが維持されます。

エージェントでまだできないこと

  • BioRender Graphingでまだ提供されていないグラフの種類を作成したり、分析を実行したりすることはできません。
  • グラフ要素をクリックしてチャットに送信することはできません。代わりに、変更したい内容を説明してください。

仕組み

  • 対応しているグラフと分析のみ:エージェントは利用可能なグラフと分析でのみ機能します。
  • BioRender独自の方法:エージェントは、BioRender独自の検証済み分析方法を使用します。これは、「run new analysis」をクリックしたときに利用できるものと同じです。
  • 不確かな場合は確認します:どの変数やグループを指しているのか判断できない場合は、質問します。
  • 実行できないことを伝えます:リクエストが対応していない場合や失敗した場合、エージェントは実行できなかった内容を説明します。

データとプライバシー

Graphingのエージェント機能を使用する場合、データはBioRenderによって安全に保護されます。エージェントはBioRenderに組み込まれた分析およびグラフ作成ツールを通じて動作するため、データを読み取ったり変更したりすることはなく、同意なしにAIのトレーニングに使用することもありません。

エージェントの場所

エージェントは「Ask BioRender」チャットボックスです。新しいGraphingファイルを初めて作成すると表示され、「Data」、「Graph」、「Analysis」のすべてのタブに表示されます。

  • 新しい空のファイルの場合:「Data」タブの中央に開き、挨拶が表示されます。
  • Data、Graph、Analysisページの場合:下部中央に表示されます。「Ask BioRender」をクリックして会話を開きます。

例:「Data」タブのGraphingエージェント。

What you will see when you first interact with the Graphing agent

例:GraphタブのGraphingエージェント(サイドパネルのオプションを開いて別の表示にすると、エージェントの表示方法を変更できます)

The graphing agent is always on any tab you select

エージェントでグラフを作成する

ステップ1:データを追加する

  1. Galleryから、「Create New」 > 「Graph」 > 「Graphing」をクリックします。
  2. メッセージ内の「Upload data」をクリックするか、チャットボックスの「+」ボタンをクリックします。
  3. ファイルを選択します。対応形式:.csv、.xls、.xlsx、.prism、.pzfx(最大50 MB)。
  4. 「Select datasets from your file」ウィンドウで、必要なデータセットを選択するか、「Select All」を選択してから「Import data」をクリックします。
  5. エージェントが追加した内容を確認し、確認できた内容を説明します。検出した変数が強調表示されます。

💡 「Upload data」または「+」ボタンを使用すると、いつでもデータセットをアップロードできます。どちらも同じインポートウィンドウを開きます。

例:Upload dataset。

Select the data sets you want to work with (Graphing agent side panel view)

別の方法で開始しますか?「Blank spreadsheet」をクリックして独自のデータを貼り付けたり入力したりすることも、「Try a sample dataset」をクリックしてサンプルデータを使って試すこともできます。詳しくは、BioRender Graphingでデータを追加する方法をご覧ください。

💡 GraphPad Prismからインポートしますか?PrismファイルをBioRender Graphingにインポートする方法をご覧ください。 

ステップ2:グラフを作成する

  1. チャットでグラフを依頼します。例:「[データセット名]からグラフを設定するのを手伝ってください。」エージェントを使ってデータをインポートした場合は、グラフの種類を推奨します。
  2. エージェントが、用量反応曲線など、データに適したグラフの種類を提案します。承認するか、別のグラフの種類を伝えます。
  3. エージェントが、数値のX軸や数値のY軸など、そのグラフに必要な要素を説明し、変数を割り当てます。
  4. グラフがグループ化に対応している場合、エージェントがオプションを提示します。オプションをクリックするか、独自の内容を入力します。
  5. エージェントがグラフの概要をまとめたプランを表示します。「Create the graph」をクリックします。
  6. エージェントが作成内容を確認し、新しいグラフにすぐ移動します。 

例:グラフの種類を提案するグラフ作成エージェント。

ステップ3:分析をRunする

  1. チャットに「run an analysis」と入力するか、実行したい分析名を入力します。グラフの作成後に、エージェントが分析を提案する場合もあります。
  2. エージェントが、グラフの種類で利用可能な分析を一覧表示します。用量反応曲線の場合は、次のとおりです。
  • Outlier Detection:データ内の外れ値を検出します
  • Area Under Curve:各グループの曲線下の総面積
  • Correlation Analysis:2つの数値変数間の関連の強さと方向
  • Linear Regression:線形関係をモデル化します
  • Nonlinear Regression:dose-responseモデルなどの曲線を適合させます
  1. エージェントがデータに適した分析を推奨します。提案をクリックするか、希望する分析を入力します。
  2. エージェントの指示に従って分析を設定します。
  3. 「Analysis」タブで結果を確認します。有意な比較がグラフに追加されます。

例:グラフの種類に応じて利用可能な分析を提案するグラフ作成エージェント。 

The Agent will set up your analysis for you

分析について詳しくは、BioRender Graphingで統計分析を実行するをご覧ください。

ステップ4:グラフをカスタマイズする

  1. Graphページで、「Ask BioRender」をクリックします。
  2. 変更したい内容を説明します。グループ、軸、凡例など、グラフの対象部分を指定します。
  3. 更新されたグラフを確認します。
  4. 結果が気に入らない場合は、左上隅の元に戻す矢印をクリックするか、操作を元に戻すようエージェントに依頼します。 

エージェントはBioRender内の同じGraphingツールを使って変更するため、グラフは手動で完全に編集できます。

例:プロンプト:「x軸上で9.899~103.1の範囲にあるCompound Bのデータポイントを赤色にする。」中央のチャットビューでエージェントを使用。

Prompting an edit with the Graphing agent

カスタマイズ方法の詳細については、グラフをカスタマイズする方法をご覧ください。

入力例

操作 入力例
グラフを開始する 「[データセット名]からグラフを設定するのを手伝ってください。」
分析をRunする 「分析をRunしてください。」
色を変更する 「Compound Bを赤色のままにして、それ以外の色をグレースケールにしてください。」
色を変更する 「線を紫色からピンク色に変更してください。」
データポイントの形を変更する 「すべてのデータポイントをひし形に変更してください。」
ポイントを強調表示する 「y = 2未満またはy = 98超のすべてのデータポイントを黒色にしてください。」

より良い結果を得るためのヒント

  • 具体的に指定する:何をどこで変更したいのかを伝えます。「色を変更して」ではなく、「Treatment 1以外のすべてのデータ系列をグレースケールにし、Treatment 1は赤色にしてください」のように入力します。
  • データに名前を付ける:「Cell Lineでグループ化」のように、データセット名、変数名、グループ名を使用します。
  • 一度に1つだけ変更する:結果を確認して元に戻しやすくなります。
  • 提案ボタンを使用する:エージェントがオプションを提示したら、入力する代わりに1つをクリックします。
  • うまくいかない場合は言い換える:結果が希望どおりでない場合は元に戻し、別の言葉で変更内容を説明します。

いつでも手動で操作する

いつでもチャットとエージェントを使わない操作を切り替えられます。

  • グラフをカスタマイズする:Graphタブの右上にある「Customize graph」をクリックして手動で編集します。
  • Graphの詳細:「Graph details」パネルの“Edit”をクリックして、データセット、変数、グループ化を変更します。
  • 新しい分析をRunする:「Analysis」パネルの「Run new analysis」をクリックします。
  • 元に戻す/やり直す:左上隅の矢印を使用します。

トラブルシューティング

「Ask BioRender」ボックスが表示されません。 

ページを更新してから、Graphingファイルを開いていることを確認してください。それでも表示されない場合は、サポートにお問い合わせください。

エージェントが依頼した内容を実行しませんでした。 

変更を元に戻してから、より具体的なリクエストでもう一度試してください。対象のグループ、軸、データポイントを指定します。エージェントが依頼された操作を実行できない場合は、その理由を説明します。

エージェントが希望していないグラフをsuggestedしました。 

希望するグラフの種類を伝えるか、DataタブのGraphsパネルから自分で選択してください。

新しい分析のRunが反応しません。 

まずグラフの詳細を確認または保存する必要があります。Graph detailsパネルが編集モードのまま開いていないか確認し、閉じるか確定してください。

ファイルをインポートできませんでした。 

ファイルが対応形式で、50 MB未満であることを確認してください。データの制限については、BioRender Graphingでデータを追加する方法をご覧ください。


よくある質問

エージェントを使用するにはGraphingのシートが必要ですか? 

エージェントはBioRender Graphingの一部です。 

エージェントには追加料金がかかりますか? 

いいえ。追加料金はかかりません。 

エージェントによってデータが変更されますか?

いいえ。グラフをカスタマイズしても、変更されるのは見た目だけです。基になるデータは変わりません。

エージェントはAIモデルのトレーニングにデータを使用しますか?

Graphingのエージェント機能を使用する場合、データはBioRenderによって安全に保護されます。エージェントはBioRenderに組み込まれた分析およびグラフ作成ツールを通じて動作するため、データを読み取ったり変更したりすることはなく、同意なしにAIのトレーニングに使用することもありません。

変更を元に戻すにはどうすればよいですか? 

左上隅の元に戻す矢印をクリックするか、Graphingエージェントに操作を元に戻すよう依頼します。やり直す矢印を使用すると、変更を再適用できます。

エージェントで任意の分析を実行できますか? 

エージェントは、グラフの種類で利用可能な分析を提示します。

Graphingエージェントなしでもグラフを作成できますか? 

はい。Dataタブの「Graphs」パネルからグラフの種類を選択し、変数を割り当てて、“Continue”をクリックします。BioRender Graphingを始めるをご覧ください。

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

この記事は役に立ちましたか?

0人中0人がこの記事が役に立ったと言っています