BioRender Graphingは、BioRenderの統計グラフ作成・分析ツールです。Graphingエージェントを使えば、生データから出版品質のグラフを数分で作成でき、プロセスのどの段階でも手動で編集できます。データのインポート、グラフの作成、外れ値の検出、統計分析を1つのワークフローにまとめているため、手動でのデータ準備や新しいツールの習得、ツール間の切り替えは必要ありません。

データを再構成せずに同じデータセットから複数のグラフを作成したり、適切な統計検定を推奨し、その理由を説明する組み込みの事前検定を使用したり、既存のPrismファイルをインポートしたりすることもできます。すべてのデータはBioRenderに安全に保存されます。

📌 ベータ版: Graphingエージェントは現在ベータ版です。 

この記事では、次の方法を説明します。

BioRender Graphingファイルを作成する

Galleryから:

  1. 左上隅の「Create New」をクリックします。
  2. 「Graph」を選択します。
  3. 「New Graphing」をクリックします。

Graphingファイルの構成

上部のタブ:「Data」、「Graph」、「Analysis」。

  • 「Data」:データセットをインポートして管理します
  • 「Graph」:グラフを作成、表示、カスタマイズします
  • 「Analysis」:統計分析を実行して確認します
  • BioRender AIエージェント:「Ask BioRender」チャットボックス。 

クリックすると会話が開きます。エージェントは3つすべてのタブで使用でき、タブを切り替えても会話とデータが保持されるため、再起動したり再アップロードしたりする必要はありません。

ステップ1:データを追加する

  1. 新しいGraphingファイルを開きます。エージェントが挨拶し、スプレッドシートのアップロード、グラフの作成、分析の実行など、できることを説明します。
  2. エージェントのメッセージにある「Upload data」をクリックするか、チャットボックスの「+」ボタンをクリックします。どちらも同じインポート処理を開始します。いつでもこの方法でデータを追加できます。
  3. ファイルを選択します。対応形式:.csv、.xls、.xlsx、.prism、.pzfx(最大50 MB)。 
  4. 「Select datasets from your file」ウィンドウで、エージェントが検出したデータセットを確認します。それぞれの行数と列数が表示されます。
  5. 使用するデータセットを選択するか、「Select All」を選択してから、「Import data」をクリックします。
  6. エージェントが追加した内容を確認します。続いて、検出した内容を説明し、検出した変数を強調表示して、グラフの種類を提案します。

Upload data

空のファイルから手動で開始するその他の方法

  1. Blank spreadsheet:自分のデータを貼り付けるか入力します。完了したら、「Re-detect variables」をクリックします。
  2. サンプルデータセットを試す:用意されたサンプルデータを使って操作します。
  3. Add dataset(右上):いつでも別のデータセットを追加できます。 

💡 GraphPad Prismからインポートしますか?BioRenderは.prismファイル(最新形式)に対応しています。古い.pzfxファイルではデータのみがインポートされます。詳しいガイドについては、GraphPad Prismからインポートするをご覧ください。 

詳しい手順とデータ制限については、BioRender Graphingでデータを追加する方法をご覧ください。

ステップ2:グラフを作成する

BioRender AIエージェントを使用する場合 

  1. データを入力すると、エージェントがグラフの種類を推奨します。自分で指定することもできます。例:「[データセット名]からグラフを設定するのを手伝ってください。」
  2. エージェントがデータに適したグラフの種類を提案し、確認を求めます。グラフの種類を確認するか、別のグラフをリクエストします。
  3. エージェントが、そのグラフに必要な内容(たとえば、数値のX軸と数値のY軸)を説明し、変数を割り当てます。
  4. エージェントがグラフの概要をまとめたプランを表示します。「Create the graph」をクリックします。
  5. エージェントがUI内の移動を自動的にサポートし、目的の場所に移動するためのクリック可能な操作も提供します。
  6. エージェントが、細胞株を比較するための分析を適用するなど、次のステップを提案します。確認するか、別の操作を依頼します。
  7. エージェントを通じてグラフを編集します。
  8. ワンクリックで編集を元に戻すか、エージェントに操作を元に戻すよう依頼します。

例:Graphingエージェントで用量反応曲線を作成する(サイドパネルにチャットを表示)。

Creating a dose response curve with the Graphing agent

💡 適切なプロンプトを作成するためのヒント

  • 使用しているデータセット、変数、グループの名前を指定します。エージェントはBioRenderが検出した変数を基に処理します。
  • どの変数またはグループを指しているのかエージェントが判断できない場合、確認を求めます。通常の言葉で回答するか、候補をクリックします。
  • 提案が適切でない場合は、代わりに何をしたいかを伝えます。
  • エージェントが実行できない操作については、完了できなかった内容を説明します。言い換えて再度試すか、以下の手動手順を使用してください。

手動で行う場合

  1. Dataタブで、右側の「Graphs」パネルを開きます。グラフの種類を検索または参照します。
  2. 作成するグラフをクリックします。Graph編集ページに移動します。
  3. Graphの詳細パネルで変数を割り当てます。各フィールドに入力すると、グラフのプレビューがリアルタイムで更新されます。
  4. プレビューが適切になったら、「Continue」をクリックします。

Graphページを確認する

  • Graphの詳細(左側):データセット、変数、グループ。「Edit」をクリックして変更します。
  • Analysis(左側):「Run new analysis」をクリックします。レポートが下に表示されます。外れ値分析(ROUT)は自動的に実行されます。
  • ツールバー(上部):「Resize graph」、「Style match」、「Comment」。
  • Customize graph(右上):Customize graphパネルを開きます。
  • Displayed data(グラフの下):表示されている内容の元となるデータ。
  • 「Ask BioRender」(中央下):クリックしてエージェントとの作業を続けます。
Graph tab view

💡 新しい統計分析を実行したりグラフをカスタマイズしたりするには、グラフの詳細を確認または保存する必要があります。「Run new analysis」が反応しない場合は、Graphの詳細パネルが編集モードのまま開いていないか確認してください。開いている場合は、先に閉じるか内容を確定してください。

後からグラフの詳細を編集する

Graphの詳細(種類、変数、データセット)は、いつでも「Edit」で再度開くことができます。編集モードでグラフの詳細を再度開くと、変更を確定する前に、保存されていない編集内容を保持するか破棄するかを尋ねるプロンプトが表示されます。

Manual Edit option

ステップ3:外れ値の検出を確認する

外れ値の検出はすべてのグラフで自動的に実行されます。手動で開始する必要はありません。BioRenderは外れ値の検出にROUT(Robust regression and Outlier removal)法を使用します。 

エージェントに外れ値の検出をグラフに追加するよう依頼することもできます。

Outlier detection

表示される内容

  • 検出された外れ値の数が左側のパネルに表示されます。
  • 外れ値は自動的に検出され、グラフ下のデータテーブルで強調表示されます。
  • 外れ値レポートをクリックすると、次の内容を示す完全な外れ値レポートが開きます。
    • 分析されたデータポイントの総数
    • 検出された外れ値の数
    • グループ別の外れ値の内訳

Qパラメータで感度を調整する

外れ値をどの程度厳しく識別するかを変更したい場合は、Qパラメータを調整できます。

  1. 外れ値レポートを開きます。
  2. 「Update settings」をクリックします。
  3. 0.1~10のQ値を入力します。
    • 低い値=より厳格(外れ値としてフラグ付けされる数が少ない)
    • 高い値=より寛容(外れ値としてフラグ付けされる数が多い)
  4. 「Rerun」をクリックして、更新されたしきい値を適用し、修正された結果を確認します。

💡 これは、特定の外れ値がどの程度境界的なものかを確認したい場合に便利です。たとえば、データポイントが明確な外れ値なのか、境界付近にあるだけなのかを確認できます。

データポイントを除外する

外れ値や、除外したいその他のデータポイントを処理するには、2つの方法があります。

  1. 「Exclude individual data points」:外れ値でないものも含め、任意のデータポイントを右クリックして手動で除外します。
  2. 「Exclude all detected outliers at once」:外れ値レポートの「Exclude all outliers」チェックボックスを使用すると、ワンクリックですべての外れ値を除外または除外解除できます。オンまたはオフにして結果を比較します。

詳しくは、外れ値検出(ROUT法)についてをご覧ください。

ステップ4:グラフをカスタマイズする

BioRender AIエージェントを使用する場合:「Ask BioRender」をクリックして、変更内容を説明します。例:

  • 「色をグレースケールにしてください。ただし、Compound Bは赤のままにしてください。」
  • 「すべてのデータポイントをひし形に変更してください。」
  • 「y = 2未満またはy = 98を超えるすべてのデータポイントを黒にしてください。」
  • 「x軸上で9.899~103.1の範囲にあるCompound Bのデータポイントを赤にしてください。」

元のデータは変更されません。エージェントはBioRenderの同じGraphingツールを使って変更するため、グラフは手動で完全に編集できます。左上隅の元に戻す矢印を使うか、エージェントに操作を元に戻すよう依頼すれば、変更を元に戻せます。 

手動で行う場合:Graphタブの右上にある「Customize graph」をクリックします。Customize graphパネルでは、次の操作を行えます。

  • Display data:データのプロット方法を選択します。
  • Appearance:テーマ、フォント、色を設定します。
  • Additional settings:グラフタイトル、軸タイトル、軸ラベル、凡例の表示・非表示を切り替えます。

グラフの特定の部分を編集するには、データ、軸、凡例、タイトルのいずれかを直接クリックし、「Customize Graph」タブを使用します。

プロンプト、ヒント、すべての手動オプションについては、グラフをカスタマイズする方法をご覧ください。

ステップ5:統計分析をRunする

BioRender AIエージェントを使用する場合

  1. チャットに「run an analysis」と入力するか、実行したい分析名を入力します。
  2. エージェントが、グラフの種類で利用できる分析を一覧表示します。 
  3. 候補をクリックするか、希望する分析を入力します。
  4. エージェントの指示に従って分析を設定します。 
  5. 「Analysis」タブで結果を確認し、構造化フォームで最終調整を行います。 
  6. 次に「Run Analysis」をクリックします。

💡 利用できる分析はグラフの種類によって異なります。エージェントはGraphingが対応している分析のみを実行します。

手動で行う場合

  1. Graphページで「Run new analysis」をクリックします。
  2. 3つのセクションで構成されたフォームが表示されます。

セクション1:分析の種類

可能な場合、BioRender Graphingの分析ガイダンスは、データに基づいて最適な統計検定を自動的に推奨します。推奨された検定にはバッジが表示されます。

  • ドロップダウンを開いて利用可能なすべての選択肢を表示し、推奨を上書きできます。
  • データの前提条件に合わない検定を選択した場合(たとえば、データが正規分布でないのにパラメトリック検定を選択した場合)、推奨された検定が適している理由を説明する警告が表示されます。
  • データが要件を満たしていない場合、一部の検定がグレー表示されることがあります。理由を確認するには、ツールチップを確認してください。

カテゴリグループを選択する

  • デフォルトでは、グラフ内のすべてのグループが含まれます。
  • 今回の分析に含めないグループの選択を解除します。

セクション2:分析を微調整する

このセクションでは、分析の統計設定を調整できます。利用できるオプションは、選択した分析の種類によって異なる場合があります。BioRenderは、データに対して実行された事前検定に基づいて設定を推奨しますが、必要に応じて変更できます。

  • Data setup:分析用にデータをどのように構成するかを定義します。利用できるオプションは、選択した手法によって異なります。
  • Advanced options:利用可能な場合、このセクションを展開して追加の設定にアクセスします。
  • Assumptions:一部の分析には、データに関する設定可能な前提条件が含まれます。該当する場合は、これらの設定を確認して調整できます。

セクション3:Optionsと追加設定

一部の分析には、結果の比較方法や計算方法を細かく調整できる追加オプションがあります。これらの設定は、選択した分析に関連する場合のみ表示され、推奨オプションが自動的に適用されます。

  • Comparisons:該当する場合、グループまたは条件の比較方法を選択します。すべてのグループを比較するか、特定の比較を選択できます。
  • Follow-up test:一部の分析には、グループ間の差を調べるための任意の追加検定があります。手法を選択するか、推奨オプションを使用できます。
  • Automatic recommendations:BioRenderは分析の種類とデータに基づいて適切な設定を提案しますが、必要に応じて調整できます。

結果を表示する

分析が実行されると:

  • 完全な結果テーブルと記述統計がAnalysisパネルに表示されます。
  • 有意な比較が有意差マーカー付きでグラフに自動的に追加されます。
  • Graphパネルのチェックボックスを使用して、グラフに表示する結果を切り替えます。
  • 同じグラフで複数の分析を実行し、どの分析を表示するかを管理できます。

複数のグラフを管理する:Graph Grid View

ファイルが大きくなったら、「Graph Grid View」(Graphタブ)を使用して、ファイル内のすべてのグラフを一覧で確認できます。

ビュー内を移動する

  • グラフ名で検索する
  • データセットでフィルタリングし、特定のデータテーブルのグラフに絞り込む
  • 名前、作成日、または最終更新日でSort byする

注:Graph Grid Viewに表示されるのは、現在のファイル内のグラフのみです。他のファイルのグラフはここには表示されません。

一括操作

1つ以上のグラフを選択すると、一括操作にアクセスできます。

  • 「Duplicate」:既存のグラフのバリエーションを作成する場合に便利です(たとえば、棒グラフから箱ひげ図に変更したり、1つの変数を調整したりできます)。
  • 「Style match」:1つのグラフのスタイルをコピーして、他のグラフに適用します(下記参照)。
  • 「Delete」。

Style match 

「Style Match」を数回クリックするだけで、フォント、色、軸の書式、間隔など、見た目が統一されたグラフを作成できます。個々のグラフを開かずに、Graph Grid Viewからスタイル全体を適用できます。

使用方法

  1. Graph Grid Viewまたは個々のグラフで、スタイルのコピー元にするグラフを選択します。
  2. 「Style match」 > 「Copy style」をクリックします。
  3. 1つ以上の対象グラフを選択します。
  4. 「Paste style」をクリックします。
  5. 選択したグラフに、最初に選択したグラフのスタイルが適用されます。

スタイルをコピーする際は、適用するカテゴリを選択できます。

  • Graph styling(デフォルトで選択):色、間隔、線、フォント
  • Statistics markings(デフォルトで選択):ペアワイズ比較、最適曲線
  • Graph size and dimensions:一貫性のあるパネル図に便利
  • Axis range and scale:対数スケールまたはカスタム目盛り間隔を設定している場合に便利

詳しい手順については、BioRender GraphingでStyle Matchを使ってグラフのスタイルをコピーする方法をご覧ください。

グラフと分析をエクスポートする

グラフをエクスポートする方法

  1. エクスポートするグラフを「Graph」タブで開きます。正しいタブ(Data、Graph、またはAnalysis)を開いていることを確認してください。選択したタブがエクスポートされます。
  2. BioRenderページ右上にある青い「Export」ボタンをクリックします。
  3. 希望するファイル形式と解像度を選択します。
  4. 「Export」をクリックしてグラフをダウンロードします。

分析をエクスポートする方法

  1. エクスポートする分析を「Analysis」タブで開きます。
  2. BioRenderページ右上にある青い「Export」ボタンをクリックします。
  3. エクスポートする分析を選択します。
  4. 「Export」をクリックして、分析を.CSVファイルまたはPDFファイルとしてダウンロードします。

❗ 重要:別のアプリケーションでグラフを編集する必要がある場合は、SVGファイルとしてエクスポートしてください。その後、Adobe IllustratorやAffinity Designerなどのベクター編集ツールで編集できます。

GraphPad Prismからインポートする

既存のPrismファイルがある場合は、データ、グラフ、分析を含めてBioRender Graphingに直接インポートできます。

対応ファイル形式

  • BioRenderは.prismファイル形式(最新のPrism形式)に対応しています。
  • 古い.pzfxファイルは部分的に対応しています。データはインポートされますが、グラフと分析はインポートされません。
  • グラフと分析を保持したまま.pzfxファイルをインポートするには、まずGraphPad Prismで.prismファイルとして再保存してからインポートします。

インポート方法

  1. Graphingファイルで「Upload data」(またはBioRender AIエージェントのチャットにある「+」)をクリックし、.prismファイルを選択します。
  2. ファイル内のすべてのデータセットが表示されます。すべてを選択するか、特定のデータセットを選択します。
  3. グラフと分析のインポートはデフォルトでオンになっています。生データのみを使用する場合は、このオプションの選択を解除します。
  4. 「Import data」をクリックします。

詳しくは、 PrismファイルをBioRender Graphingにインポートする方法をご覧ください。

イラストにグラフを追加する

BioRender Graphingファイルは、BioRenderのイラストファイルで直接使用できます。

  1. イラストエディターから:エディター内のグラフ挿入パネルを使用して、BioRender Graphingファイルのグラフを参照して挿入します。キャンバス上で、個々のグラフ要素をクリックしてインラインでスタイルを設定できます。
  2. Graph Grid Viewから:1つ以上のグラフを選択し、「Add to illustration」を使用して既存のイラストファイルに追加します。送信先のファイルを選択するウィンドウが表示されます。

サポートが必要ですか? support@biorender.comからサポートチームにお問い合わせいただくか、右下にある"Chat With Us"バブルをクリックしてライブチャットを開始してください。

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

この記事は役に立ちましたか?

8人中4人がこの記事が役に立ったと言っています