BioRender Graphingにデータを追加する方法 BioRender Graphingにデータを追加する方法

BioRender Graphingにデータを追加する方法

📌 ベータ版: Graphingエージェントはベータ版です。 

BioRender Graphingファイルにデータを追加する方法は2つあります。

  1. Graphingエージェントを使用する: チャットにファイルをアップロードします。
  2. 手動で行う: 「データ」タブからファイルをアップロードするか、空のスプレッドシートにデータを入力または貼り付けます。

どちらの方法でも、Smart Data Importが変数を自動的に検出するため、データの形式を変更する必要はありません。2つの方法はいつでも切り替えられます。

Graphingエージェントを使用する

BioRenderのAIエージェントは、Smart Data Importを使用して、データの構造や形式にかかわらず、実験データをグラフ作成用に自動的に解釈して準備します。ほとんどの形式では、データを手動で並べ替えたり、コピーしたり、貼り付けたりする必要はありません。また、1つのデータセットから複数の種類のグラフを作成できるため、データを再フォーマットしたり複製したりせずに、さまざまな可視化を柔軟に試すことができます。元のデータが変更されることはありません。

新しいグラフファイルを作成する

  1. Galleryから「新規作成」 > 「Graph」 > 「Graphing」をクリックします。
  2. 以前のデータセットで作業を続ける場合は、既存のGraphファイルを開くこともできます。

データセットをアップロードする

  1. エージェントのメッセージで「データをアップロード」をクリックするか、チャットボックスの「+」ボタンをクリックします。
  2. ファイルを選択します。対応形式: .csv、.xls、.xlsx、.prism、.pzfx(最大50 MB)。 
  3. 「ファイルからデータセットを選択」ウィンドウで、目的のデータセットを選択するか、「すべて選択」を選択してから「データをインポート」をクリックします。複数のシートがあるファイルでは、利用可能なすべてのシートが表示されます。
  4. .prismファイルでは、グラフと解析のインポートがデフォルトで有効になっています。生データのみが必要な場合は、チェックを外します。 
  5. エージェントが追加した内容を確認し、データを説明して、検出した変数を強調表示します。

例: Graphingエージェントのチャット(中央のチャットビュー)でデータをアップロードする

Upload your data with the Graphing agent

例: データセットを選択する(中央のチャットビュー)

Choose the data you want to import

💡 チャットメッセージとしてファイルを送信することはできません。「データをアップロード」または「+」ボタンを使用してください。どちらも同じインポートウィンドウが開きます。

変数を確認する

これらの編集は手動で行います。エージェントがデータを変更することはありません。

  • 変数名をクリックして編集します。
  • 必要に応じて、変数の強調表示されたセルを編集します。
  • 変数を追加または削除することもできます。

Review the variables

最初のグラフを作成する

エージェントがデータに適したグラフの種類を提案します。指示に従うか、希望するグラフをエージェントに依頼してください。詳しい手順については、BioRender GraphingでGraphingエージェントを使用する方法をご覧ください。

後からデータを追加する

チャットボックスの「+」ボタンをクリックして、別のファイルをアップロードします。


手動で行う

オプション1: ファイルをアップロードする(Smart Data Import)

Smart Data Importは、データの構造にかかわらず、グラフ作成用にデータを解釈して準備します。データを並べ替えたり、コピーしたり、貼り付けたりする必要はありません。1つのデータセットから複数の種類のグラフを作成することもできます。

オプション2: Blank spreadsheet

任意の形式でデータを入力または貼り付けます。完了したら、変数を再検出すると、BioRenderがグラフを作成できる状態に整えます。

Smart Data Importの使用方法

  1. 新しいグラフファイルを作成する
    • Galleryから"Create New" > "Graph" > "Graphing"をクリックします。
    • 以前のデータセットで作業を続ける場合は、既存のGraphファイルを開くこともできます。
  2. データセットをアップロードする
    • 「データ」タブで"Upload dataset"をクリックします。
    • ファイルを選択します(対応形式: .csv、.xls、.xlsx、.prism、.pzfx — 最大50 MB)。
    • 複数のシートがあるファイルでは、利用可能なすべてのシートが表示されます。すべて選択するか、1つを選択します。

Drag and drop your data in or start from a blank spreadsheet or sample dataset

  • .prismファイルでは、グラフと解析をインポートするオプションがデフォルトで有効になっています。生データのみが必要な場合は、チェックを外します。
  1. インポートするデータセットを選択します。

Choose the data you want to import

  1. データと変数を自動的に識別します。システムは次の処理を自動的に行います。
    • スプレッドシート内に存在する変数を識別する 
    • 結合されたヘッダーセルを処理する
    • 注釈(メインデータセット外にある装置出力のヘッダーなど)を無視する
    • 空の行または列を無視する
  2. 変数を確認する
    • 変数名をクリックして編集します。
    • 必要に応じて、変数の強調表示されたセルを編集します。
    • 変数を追加または削除することもできます。

💡 GraphPad Prismからインポートしますか?BioRenderは.prismファイル(最新形式)に対応しています。古い.pzfxファイルではデータのみがインポートされます。詳しいガイドについては、GraphPad Prismからインポートするをご覧ください。


すべてのデータセットに関する推奨事項

  • アップロードの場合: Fileサイズの上限(すべてのファイル形式): 50 MB
  • アップロードまたは空のスプレッドシートへの手動入力の場合: グラフの作成と解析の実行には、Recommended最大5,000データポイントを推奨します。これを超えるファイルでは、パフォーマンスが大幅に低下する可能性があります。

CSVまたはExcelファイルのRecommendedデータ上限

最適なパフォーマンスを得るには、データを次の上限内に収めてください。

上限 Recommended値
最大列数 50
最大行数 10,000

これらの上限により、次のことが確保されます。

  • 高速な処理時間(10秒未満)
  • 統計解析機能との互換性
  • すべてのデータタイプで信頼性の高いインポート

Prism Fileの上限

  • Prismファイル内のデータテーブルは最大50個

prismファイルのRecommendedデータ上限

上限  値
テーブルあたりの行数 10,000
テーブルあたりの列数 100
データポイントの合計(すべてのテーブル) 100,000

注: Prismファイルに多数のテーブルがある場合は、データポイントの合計を100,000未満にしてください(例: 10テーブル × 10,000ポイント)。

データセットの構成

インポートすると、各データセットが「データ」タブの下部にタブとして表示されます。  データセットをクリックして切り替え、表示できます。アクティブなデータセットの変数は左パネルに表示されます。

例: サイドパネルのエージェントチャットビューに表示されたデータタブ。

Alternate between datasets in the tabs below

データビューでは、次の操作を行えます。

  • 変数、行、列を手動で追加または削除する
  • 変数名を変更する
  • 各データセットにリンクされているグラフを確認する

Add, delete or rename your variables

次のステップ

データを追加したら、グラフの作成を始める準備が整います。最初のグラフを作成するには、右側のパネルにある「データ」タブから「Create New Graph」をクリックするか、Graphタブに移動し、解析ガイダンスを適用して適切な統計検定を選択し、BioRenderを離れることなくビジュアルをカスタマイズします。

BioRender Graphingで統計解析をRunする方法を確認する →

サポートが必要ですか? support@biorender.comからサポートチームにお問い合わせいただくか、右下隅にある"Chat With Us"バブルをクリックしてライブチャットを開始してください。

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

この記事は役に立ちましたか?

6人中3人がこの記事が役に立ったと言っています