グラフを作成した後、最初からやり直さずに細かく調整できます。Graphingエージェントに変更を依頼するか、リアルタイムプレビューを見ながら手動で編集できます。希望どおりの最終結果になるまで、ラベル、スケール、間隔、グループ化、色を更新できます。元のデータが変更されることはありません。

📌 ベータ版: Graphingエージェントはベータ版です。 

始める前に: グラフを開く

グラフのカスタマイズを始めるには、Graphingページ上部のGraphタブでグラフを選択します。このタブでは、同じデータセットのグラフにもアクセスできます。

他のデータセットに関連付けられている以前のグラフは、メインのGalleryで確認できます。

カスタマイズ方法を選択する

  1. Graphingエージェントでカスタマイズ: 変更内容を自然な言葉で説明します。
  2. 手動でカスタマイズ:「グラフをカスタマイズ」パネルを使用し、カスタマイズするグラフの部分を選択します。

いつでも2つの方法を切り替えられます。


Graphingエージェントでカスタマイズする

エージェントによるグラフのカスタマイズ方法

エージェントはデータ、Graph、分析の各タブで利用でき、タブを切り替えても会話が保持されます。BioRender内のGraphingと同じツールを使って変更するため、グラフは引き続き手動で編集できます。また、Graphingがサポートするグラフや分析にも対応しています(現時点では生存曲線はサポートされておらず、近日中に対応予定です)。

エージェントには次の更新を依頼できます。

  • 色
  • ラベル
  • 軸
  • データポイントのスタイル
  • 特定のデータセットまたは処理の外観

エージェントがリクエストに対応できない場合は、その旨を確認します。リクエストを言い換えるか、「グラフをカスタマイズ」パネルを使用してください。

手順

  1. いずれかのグラフ作成タブ(データ、Graph、分析)で、ページ下部中央の「BioRenderに依頼」をクリックします。エージェントをクリックしてチャットを開くか、「左側にドッキング」をクリックしてタブの横にチャットを表示します。

    Graphing agent chat options

  2. 変更内容を説明します。
  3. グラフ上で変更内容を確認します。結果が気に入らない場合は、左上の元に戻す矢印をクリックするか、エージェントに操作を取り消すよう依頼します。 
  4. 続けて操作します。別の変更を依頼するか、手動で編集します。
Edit the graph with a simple chat request

Run分析を実行して結果を表示する

エージェントに分析の実行を依頼できます。結果は「分析」 タブに表示されます。 

プロンプトの例

  • 「化合物Bを赤のままにして、それ以外の色をグレースケールにしてください。」
  • 「すべてのデータポイントをひし形に変更してください。」
  • 「y = 2未満またはy = 98を超えるすべてのデータポイントを黒にしてください。」
  • 「活性が98%を超える、または2%未満のすべてのデータポイントの塗りつぶしを赤にしてください。」
  • 「X軸を黒から青に変更してください。」 

プロンプトの例: 

変更前: 「y = 2未満またはy = 98を超えるすべてのデータポイントを黒にしてください」

変更後

エージェントへのプロンプト作成のヒント

  • 最良の結果を得るには、変更したい内容と、変更を適用する場所を具体的に指定してください。たとえば、「色を変更してください」ではなく、「Treatment 1以外のすべてのデータ系列をグレースケールにし、Treatment 1は赤にしてください」と指定します。
  • エージェントが判断できない場合は、操作対象の変数またはグループを確認します。

データは変更されません

Graphingのエージェント機能を使用する場合、データはBioRenderによって安全に保護されます。エージェントは、科学者による検証済みのBioRender内蔵の分析・グラフ作成ツールを通じて動作するため、データを読み取ったり変更したりすることはなく、同意なしにAIのトレーニングに使用することもありません。

ファイルはBioRenderに安全に保存され、共有相手として選択したチームメイトのみが表示または編集できます。

利用可能状況と使用方法

Graphingエージェントはベータ版です。Graphingエージェントの使用に追加料金はかかりません。Graphing製品に含まれています。 


手動でカスタマイズする

グラフを作成する

  1. データタブのデータセットから、作成するグラフをクリックします。
  2. Graph編集ページに移動します。
  3. 変数を割り当てます。各フィールドに入力すると、グラフのプレビューがリアルタイムで更新されます。
  4. プレビューが適切になったら、「Continue」をクリックします。

例: グラフを手動でカスタマイズするタブ

カスタマイズオプション:

  • データの外観(色、境界線、間隔)
  • X軸とY軸(スケール、ラベル、書式)
  • カテゴリ軸上のグループの並べ替え
  • 凡例(位置、テキスト、間隔)
  • タイトルと軸タイトル(表示切り替え、フォント、サイズ、色)
  • 分析結果の表示(有意差マーカー、p値、ブラケット、間隔)

「グラフをカスタマイズ」パネルを開く

Graphタブの右上にある「Customize graph」をクリックします。画面右側にパネルが開き、次のセクションが表示されます。

  • データの表示: データのプロット方法を選択します。
  • 外観: カラーテーマ、フォント、色を設定します。
  • 追加設定: グラフタイトル、軸タイトル、軸ラベル、凡例の表示と非表示を切り替えます。

グラフの特定の部分を編集するには、その部分を直接クリックします。パネルが更新され、データ、軸、凡例、タイトルなど、その要素のオプションが表示されます。

データの外観オプション

  1. 「Graph」タブの右上にある「グラフをカスタマイズ」をクリックします。
  2. 次に、編集するグラフの領域(データなど)を直接クリックします。「データの外観Options」メニューが開きます。
  3. このメニューでは、次の操作ができます。
    • カラーパレットと境界線の色を変更する
    • 境界線の幅と角の半径を調整する
    • グループ間、グループ内、グラフの余白の間隔を変更する

用量反応曲線など、データポイントを含むグラフでは、次の項目も設定できます。 

  • グループのスタイル: カラーテーマと各グループの色
  • データポイント: ポイントの形状、サイズ、塗りつぶし、境界線の色、境界線の幅
  • 最適曲線: 線の色

例: データを選択したときのデータの外観タブ。

軸のカスタマイズ

  1. X軸またはY軸をクリックして、軸のカスタマイズメニューを開きます。
  2. 軸の線とラベルの書式を調整します。
  3. 連続(数値)軸では、次の方法でスケールを変更できます。
    • 最小値と最大値を手動で入力する
    • プラス/マイナスボタンで段階的に変更する

例: X軸のカスタマイズ。

カテゴリ軸上のグループを並べ替える

元のデータセットを並べ替えずに、カテゴリ軸上のグループを並べ替えられます。

グループを並べ替えるには:

  1. カテゴリ軸をクリックして軸パネルを開きます。
  2. 「Sort by」コントロールで並べ替え方法を選択します。
  • 元の順序: デフォルトの順序を維持します
  • アルファベット順: AからZまたはZからAの順に並べ替えます
  • 値(中央値)順: 中央値の昇順または降順に並べ替えます
  • カスタム: ドラッグ&ドロップ画面を開き、独自の順序を設定します
  1. 各並べ替えオプションには、昇順/降順の切り替えがあります。

例: 「Sort by」パネル。

カスタム順序を使用する

  • 画面内で行をドラッグして並べ替えます。
  • 「Flip order」または「Reset order」を使用してすばやく調整します。
  • 各行には、キーボードまたは単一ポインターで移動するための上/下ボタンもあります。

例: カスタム順序の使用。

💡 注: ドラッグ&ドロップによる並べ替えは画面内でのみ機能します。グラフ上でグループを直接ドラッグすることはできません。カスタム順序の途中にカテゴリを追加または削除すると、他のグループが移動する場合があります。末尾への追加と名前の変更は安全です。画面内でもう一度ドラッグすれば、ずれを修正できます。

凡例のカスタマイズ

  1. 凡例をクリックします。
  2. 凡例のカスタマイズメニューのドロップダウンを開くと、次の操作ができます。
    • 位置を調整する(左、右、上、下)
    • テキストの向きとサイズを変更する
    • 間隔を変更する

境界線や背景を追加したり、凡例にタイトルを付けたりすることもできます。

例: 凡例のオプション。

タイトルと軸タイトルのカスタマイズ

  1. タイトルまたはいずれかの軸タイトルをクリックして、カスタマイズメニューを開きます。
  2. 次の操作ができます。
    • タイトルの表示と非表示を切り替える
    • テキストスタイルを設定する
    • フォント、サイズ、間隔、色を調整する

例: タイトルと軸タイトルのカスタマイズ。

分析結果の表示とスタイル設定

分析タブから分析をRunし、以下の手順で結果をグラフに表示してスタイルを設定します。

分析を表示する方法

分析を実行すると、グラフに表示できます。ANOVAsの場合、これはペアワイズ比較(たとえばTukey検定)が選択されている場合にのみ適用されます。

  1. 分析を実行すると、グラフパネルに新しいセクションが表示され、このグラフで実行したすべての分析が一覧表示されます。
  2. 分析を展開して、すべてのペアワイズコントラストを表示します。
  3. デフォルトでは、有意な比較があらかじめ選択され、グラフに自動的に表示されます。
  4. 個々の比較を選択または選択解除すると、有意でない比較を含め、表示または非表示を切り替えられます。

例: 分析の表示。 

分析の表示方法をカスタマイズする

グラフ上の有意差線またはブラケットをクリックして、外観メニューを開きます。ここでは次の操作ができます。

  • アスタリスク(*)表示とp値表示を切り替える
  • ブラケットのスタイル、フォント、線のサイズを変更する
  • 間隔と位置を調整する

例: アスタリスクの表示。 

💡 ヒント: 同じグラフで複数の分析を実行し、チェックボックスで表示する結果を制御できます。異なる検定方法を比較する場合に便利です。

分析の実行について詳しくは、統計分析を実行するをご覧ください。

サポートが必要ですか? support@biorender.comまでサポートチームにお問い合わせいただくか、右下の「Chat With Us」バブルをクリックしてライブチャットを開始してください。

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

この記事は役に立ちましたか?

12人中1人がこの記事が役に立ったと言っています