BioRender GraphingでHeatmapsとWell Plate Heatmapsを作成する BioRender GraphingでHeatmapsとWell Plate Heatmapsを作成する

BioRender GraphingでHeatmapsとWell Plate Heatmapsを作成する

温度の測定値、遺伝子発現レベル、ウェルプレートアッセイなど、グリッド状の構造全体にわたるパターン、強度、変動を示すデータを扱う場合、ヒートマップはデータを可視化する優れた方法です。ウェルプレートヒートマップとヒートマップでは、色を使って値を表すことで、傾向や外れ値をすばやく特定でき、結果の解釈や共有が容易になります。ここでは、BioRender Graphingで作成する方法を説明します。

📌 ベータ版: Graphingエージェントはベータ版です。 

始める前に

BioRender Graphingには、2種類のヒートマップがあります。

  1. 通常のヒートマップ: 汎用性が高く、さまざまなデータセットに使用できます。
  2. ウェルプレートヒートマップ: ウェルプレートのデータ向けに設計されており、各セルがプレートの行と列を表します。

どちらの方法でヒートマップを作成する場合も、次の点に注意してください。

  • データセット内の各値は、ヒートマップ上の同じ位置に対応します(たとえば、1行目1列目は左上隅に配置されます)。
  • データセットに独自のデータを直接貼り付けることができます。
  • Smart Data Importがデータを整理します。

ヒートマップの作成方法を選択する

  1. Graphingエージェントを使用する: データをアップロードし、作成したいヒートマップを説明します。
  2. 手動で作成する: グラフパネルからヒートマップを選択し、変数を自分で割り当てます。

2つの方法は、いつでも切り替えることができます。

Graphingエージェントを使用する

ステップ1: データを追加する

  1. 新しいGraphingファイルを開きます。
  2. エージェントのメッセージ内にある「データをアップロード」をクリックするか、チャットボックスの「+」ボタンをクリックします。
  3. ファイルを選択し、使用するデータセットを選択して、「データをインポート」をクリックします。
  4. エージェントがデータを説明し、検出した変数を強調表示します。

Import your data

BioRender Graphingでデータを追加する方法を参照してください。

ステップ2: ヒートマップを依頼する

チャットで、作成したいヒートマップを依頼します。例: 「[データセット名]からウェルプレートヒートマップを作成してください。」エージェントがデータに適したグラフの種類を提案します。「はい」と答えるか、別の種類のグラフを希望することを伝えます。 

ask for a heatmap

ステップ3: 変数を確認してグラフを作成する

エージェントがグラフに必要な情報を伝え、変数を割り当てます。「行の因子」と「列の因子」が、行と列の識別子に一致していることを確認します。どの変数を指しているのか判断できない場合は、エージェントが質問します。設定内容に問題がなければ、「グラフを作成」をクリックします。 

Check your variables and create your graph

ステップ4: ヒートマップをカスタマイズする

「BioRenderに依頼」をクリックし、変更内容を説明します。例: 「ヒートマップの色を青から赤に変更してください。」 

  • 「カラーバー」や「行ラベル」など、カスタマイズしたい部分の名前を指定します。グラフ要素をクリックしてチャットに送信することはできません。
  • 変更を元に戻したい場合は、左上隅の元に戻す矢印をクリックするか、エージェントに操作を取り消すよう依頼します。
  • エージェントが対応できない操作については、完了できなかった内容を伝えます。依頼を言い換えるか、「Graphをカスタマイズ」パネルで手動編集してください。 

Customize your heatmap

エージェントの詳細については、BioRender GraphingでGraphingエージェントを使用する方法(ベータ版)を参照してください。


手動で作成する

ステップ1: データを追加する

「データ」タブで「Blank spreadsheet」をクリックし、データを貼り付けるか入力します。

ステップ2: ヒートマップまたはウェルプレートヒートマップを選択する

「新規作成」をクリックし、Graphメニューを開きます。「ヒートマップ」または「ウェルプレートヒートマップ」を選択します。

ステップ3: 変数を追加する

「行の因子」、「列の因子」、「値」の変数を指定します。行の因子と列の因子には、それぞれ行と列の識別子を含む変数を設定します。Graphの詳細パネルで各変数を割り当てます。プレビューに問題がなければ、「Continue」をクリックします。

ステップ4: ウェルプレートまたはヒートマップをカスタマイズする

他のBioRender Graphingの可視化と同様に、フォント、グラフタイトル、軸ラベルなど、ヒートマップのさまざまな要素をカスタマイズできます。

Graphタブの右上にある「グラフをカスタマイズ」をクリックするか、変更したいグラフの部分をクリックします。次の項目をカスタマイズできます。

  • 独立軸
  • 従属軸
  • 凡例
  • Graphタイトル
  • サンプルデータ

ヒートマップとウェルプレートヒートマップの両方:

  • データの正規化: 行または列ごとにスケールを適用します。行または列ごとにZスコア標準化が実行されます。値のラベル、要素の色、カラーバーは、変更内容を反映して自動的に調整されます。
  • カラーバーのカスタマイズ: カラーバーをクリックしてカスタマイズメニューを開くと、プロット上の位置を変更したり、境界線と背景を調整したりできます。

ヒートマップのみ:

  • ヒートマップの形状: デフォルトの形状は正方形です。「角の半径」を大きくすると、角を丸くできます。
  • 間隔と余白: セル間の間隔、および行と列のラベルとセルの間の余白を調整します。間隔を0に設定すると、データポイント間の隙間がなくなります。余白を設定すると、追加のスペースが確保されます。

ウェルプレートヒートマップのみ:

  • ウェルプレートの境界線: デフォルトでは角が丸くなっています。ヒートマップ上の任意の場所をクリックして、境界線の設定を調整します。
  • ウェル表示のカスタマイズ: ウェル間の間隔、境界線の幅、境界線の色を可視化に合わせて調整します。
  • 余白とパディング: 余白は行と列のラベルとプレートの間隔を調整します。パディングはウェルとプレートの端の間のスペースに影響します。

すべてのカスタマイズオプションについては、グラフをカスタマイズする方法を参照してください。

トラブルシューティングのヒント

ウェルプレートヒートマップに空のウェルがありますか? 

データと一緒に空のウェルを表示する場合は、これらのウェルの行名と列名を入力してください。ラベルが空白のままだと、ヒートマップが不完全に表示される場合があります。

クラスタリングや分析のオプションが必要ですか? 

これらの機能の開発に積極的に取り組んでいます。今後の更新をお待ちください。エージェントはGraphingがサポートする分析のみを実行するため、現時点ではクラスタリングを実行できません。 

ヒートマップの種類を切り替えますか? 

ドロップダウンメニューから、通常のヒートマップとウェルプレートヒートマップを切り替えることができます。ただし、すべてのカスタマイズが引き継がれるわけではないため、切り替え後に一部の設定を調整する必要がある場合があります。別の可視化タイプを試す前に、グラフを複製することをおすすめします。

エージェントが依頼したヒートマップを作成しませんでした。 

希望するヒートマップの種類を伝えるか、データタブの「グラフ」パネルから自分で選択してください。

サポートが必要ですか? support@biorender.comでサポートチームにお問い合わせいただくか、右下隅にある「Chat With Us」バブルをクリックしてライブチャットを開始してください。

 

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

この記事は役に立ちましたか?

0人中0人がこの記事が役に立ったと言っています