BioRender Graphingにデータを追加する方法 BioRender Graphingにデータを追加する方法

BioRender Graphingにデータを追加する方法

BioRender Graphingファイルにデータを取り込む方法は2つあります。

  1. Smart Data Import - ファイルをドラッグ&ドロップまたはアップロードすると、変数が自動的に検出されます。
  2. Blank spreadsheet - データを手動で入力または貼り付けます。

データをインポートする方法

オプション1:ファイルをアップロードする(Smart Data Import)

Smart Data Importは、実験データの構造や形式に関係なく、データを自動的に整理、解釈し、グラフ作成用に準備します。データを手動で並べ替えたり、コピーしたり、貼り付けたりする必要はありません。また、1つのデータセットから複数のグラフタイプを作成できるため、データを再フォーマットしたり作業を重複させたりせずに、さまざまな可視化を柔軟に試すことができます。

Smart Data Importの使用方法

  1. 新しいグラフファイルを作成します
    • Galleryから、"Create New" > "Graph" > "Graphing"をクリックします。
    • 以前のデータセットで作業を続ける場合は、既存のGraphファイルを開くこともできます。
  2. データセットをアップロードします
    • Dataタブで"Upload dataset"をクリックします。
    • ファイルを選択します(対応形式:.csv、.xls、.xlsx、.prism、.pzfx — 最大50MB)
    • 複数のシートを含むファイルでは、利用可能なすべてのシートが表示されます。すべて選択するか、1つを選択してください。

  • .prismファイルでは、グラフと解析をインポートするオプションがデフォルトでオンになっています。生データのみを使用する場合は、このオプションの選択を解除してください。
  1. インポートするデータセットを選択します。

  1. データと変数の自動識別
    • システムは以下を自動的に実行します。
      • スプレッドシートに存在する変数を識別する
      • 結合されたヘッダーセルを処理する
      • 注釈(メインのデータセット外にある装置出力のヘッダーなど)を無視する
      • 空の行または列を無視する
  2. 変数を確認します
    • 変数名をクリックして編集します。
    • 必要に応じて、変数のハイライトされたセルを編集します。
    • 変数を追加または削除することもできます。

💡 GraphPad Prismからインポートしますか?BioRenderは、.prismファイル(最新形式)に対応しています。古い.pzfxファイルではデータのみがインポートされます。詳しいガイドについては、こちらをご覧ください:GraphPad Prismからのインポート

オプション2:Blank spreadsheet

空のスプレッドシートから始め、任意の形式や構造でデータを直接入力します。入力が完了したら、変数を再検出してください。BioRenderは同じSmart Data Importプロセスを使用して変数を自動的に検出し、グラフを作成できる状態にします。

  1. 新しいグラフファイルを作成します
    1. Galleryから、"Create New" > "Graph" > "Graphing"をクリックします。
    2. 以前のデータセットで作業を続ける場合は、既存のGraphファイルを開くこともできます。
  2. Dataタブで"Blank spreadsheet"をクリックします。
  3. データをコピーして貼り付けます。
  4. 必要に応じて、任意のセルを右クリックし、行や列を追加または削除します。
  5. 完了したら"Re-detect variables"をクリックして、データセットを分析します。
    • BioRender GraphingはSmart Data Importの手順を使用して変数を自動的に検出し、グラフを作成できる状態にします。
  6. 新しいデータが入力された場合は、画面下部のプロンプトにも通知が表示されます:"新しいデータが追加されたことを検出しました。Smart Data Importを再実行しますか?"

すべてのデータセットに関する推奨事項

  • アップロードの場合:Fileサイズの上限(すべてのファイル形式):50MB
  • アップロードまたは空のスプレッドシートへの手動入力の場合:グラフの作成と解析の実行には、データポイント数5,000件以内をRecommendedします。これを超えるファイルでは、パフォーマンスが大幅に低下する可能性があります。

CSVまたはExcelファイルのRecommendedデータ上限

最適なパフォーマンスを得るには、データを以下の上限内に収めてください。

上限 Recommended値
列の最大数 50
行の最大数 10,000

これらの上限により、以下が確保されます。

  • 高速な処理時間(10秒未満)
  • 統計解析機能との互換性
  • すべてのデータタイプで信頼性の高いインポート

Prism Fileの上限

  • Prismファイル内のデータテーブルは最大50個

prismファイルのRecommendedデータ上限

上限 値
テーブルあたりの行数 10,000
テーブルあたりの列数 100
データポイントの合計(すべてのテーブル) 100,000

注:Prismファイルに多数のテーブルがある場合は、データポイントの合計を100,000件未満に抑えてください(例:10テーブル × 10,000ポイント)。

データセットの構成

インポートした各データセットは、Dataタブの下部にタブとして表示されます。タブをクリックしてデータセット間を切り替え、内容を表示できます。アクティブなデータセットの変数は、左パネルに一覧表示されます。

データビューでは、以下を実行できます。

  • 変数、行、列を手動で追加または削除する
  • 変数名を変更する
  • 各データセットにリンクされているグラフを確認する

次のステップ

データを取り込んだら、グラフの作成を始める準備は完了です。最初のグラフを作成するには、右側パネルのデータタブから「Create New Graph」をクリックするか、Graph タブに移動して、解析ガイダンスを適用し、適切な統計検定を選択して、BioRenderを離れることなくビジュアルをカスタマイズできます。

BioRender Graphingで統計解析をRunする方法 →

サポートが必要ですか? support@biorender.comまでサポートチームにお問い合わせいただくか、右下隅にある"Chat With Us"の吹き出しをクリックしてライブチャットを開始してください。

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

この記事は役に立ちましたか?

6人中3人がこの記事が役に立ったと言っています