So verwenden Sie den Graphing-Agenten in BioRender Graphing So verwenden Sie den Graphing-Agenten in BioRender Graphing

So verwenden Sie den Graphing-Agenten in BioRender Graphing

Der Graphing-Agent von BioRender ist Ihr integrierter Assistent zum Erstellen und Analysieren von Diagrammen. Überspringen Sie die manuelle Einrichtung und beschreiben Sie in einfachen Worten, was Sie untersuchen möchten. Der Graphing-Agent erstellt das Diagramm direkt aus Ihren Rohdaten. Bitte beachten Sie, dass sich der Graphing-Agent derzeit in der Betaphase befindet. 

Graphing-Agenten ausprobieren

In diesem Artikel erfahren Sie:

Wer den Graphing-Agenten verwenden kann

Der Graphing-Agent ist Bestandteil von BioRender Graphing und ohne zusätzliche Kosten verfügbar. Wenn Sie noch keinen Graphing-Platz haben, lesen Sie BioRender Graphing: Tarife und Preise.

Was der Graphing-Agent kann

  • Daten hinzufügen: Er führt Sie durch das Hochladen einer Tabelle, findet die Datensätze in Ihrer Datei und erkennt Ihre Variablen.
  • Ihre Daten beschreiben: Nach dem Import teilt er Ihnen mit, was er in Ihrem Datensatz erkennt, z. B. einen ELISA-Plattendatensatz mit Konzentrationsmessungen für verschiedene Zelllinien.
  • Diagramme vorschlagen und erstellen: Er empfiehlt einen zu Ihren Daten passenden Diagrammtyp, weist Ihre Variablen zu, bietet Gruppierungsoptionen an und erstellt das Diagramm.
  • Analysen Run: Er listet die für Ihr Diagramm verfügbaren Analysen auf, empfiehlt eine Analyse und hilft Ihnen bei der Einrichtung.
  • Ihr Diagramm anpassen: Beschreiben Sie eine Änderung, z. B. an Farben, Beschriftungen, Achsen oder Datenpunktstilen, und der Agent wendet sie an.
  • Nächste Schritte vorschlagen: Nach jedem Schritt schlägt er vor, was als Nächstes zu tun ist, z. B. eine Analyse zur Gegenüberstellung von Zelllinien anzupassen.
  • Über mehrere Tabs hinweg verfügbar sein: Der Agent ist in den Tabs „Data“, Graph und „Analysis“ verfügbar und behält Ihren Gesprächs- und Datenkontext bei, wenn Sie zwischen Tabs wechseln.

Was der Agent derzeit noch nicht kann

  • Er erstellt keine Diagrammtypen und führt keine Analysen durch, die BioRender Graphing derzeit nicht anbietet.
  • Sie können nicht auf ein Diagrammelement klicken und es an den Chat senden. Beschreiben Sie stattdessen, was Sie ändern möchten.

Wie er funktioniert

  • Nur unterstützte Diagramme und Analysen: Der Agent funktioniert nur mit verfügbaren Diagrammen und Analysen.
  • Eigene Methoden von BioRender: Der Agent verwendet die eigenen getesteten Analysemethoden von BioRender, also dieselben, auf die Sie zugreifen können, wenn Sie auf „run new analysis“ klicken.
  • Er fragt nach, wenn er unsicher ist: Wenn er nicht erkennen kann, welche Variable oder Gruppe Sie meinen, fragt er nach.
  • Er informiert Sie, wenn etwas nicht möglich ist: Wenn eine Anfrage nicht unterstützt wird oder fehlschlägt, erklärt der Agent, was er nicht durchführen konnte.

Ihre Daten und der Datenschutz

Wenn Sie die agentenbasierten Funktionen von Graphing verwenden, sind Ihre Daten bei BioRender sicher. Der Agent arbeitet über die integrierten Analyse- und Diagrammtools von BioRender. Daher liest oder verändert er Ihre Daten nicht und verwendet sie ohne Ihre Zustimmung niemals zum Trainieren von KI.

Wo Sie den Agenten finden

Der Agent ist das Chatfeld „Ask BioRender“. Es wird angezeigt, wenn Sie erstmals eine neue Graphing-Datei erstellen, und ist in allen Tabs „Data“, „Graph“ und „Analysis“ vorhanden.

  • In einer neuen, leeren Datei: Es wird in der Mitte des Tabs „Data“ geöffnet und begrüßt Sie.
  • Auf der Seite „Data“, Graph und „Analysis“: Es befindet sich unten in der Mitte. Klicken Sie auf „Ask BioRender“, um das Gespräch zu öffnen.

Beispiel: Der Graphing-Agent im Tab „Data“.

What you will see when you first interact with the Graphing agent

Beispiel: Der Graphing-Agent im Tab Graph (Sie können die Darstellung des Agenten ändern, indem Sie im Seitenbereich eine andere Ansicht auswählen.)

The graphing agent is always on any tab you select

Mit dem Agenten ein Diagramm erstellen

Schritt 1: Daten hinzufügen

  1. Klicken Sie in Ihrer Gallery auf „Create New“ > „Graph“ > „Graphing“.
  2. Klicken Sie in seiner Nachricht auf „Upload data“ oder auf die Schaltfläche „+“ im Chatfeld.
  3. Wählen Sie Ihre Datei aus. Unterstützte Formate: .csv, .xls, .xlsx, .prism und .pzfx (bis zu 50 MB).
  4. Wählen Sie im Fenster „Select datasets from your file“ die gewünschten Datensätze aus oder wählen Sie „Select All“ und klicken Sie anschließend auf „Import data“.
  5. Der Agent bestätigt, was er hinzugefügt hat, und beschreibt, was er erkennt. Die erkannten Variablen werden hervorgehoben.

💡 Verwenden Sie „Upload data“ oder die Schaltfläche „+“, um jederzeit einen Datensatz hochzuladen. Beide Optionen öffnen dasselbe Importfenster.

Beispiel: Upload dataset.

Select the data sets you want to work with (Graphing agent side panel view)

Möchten Sie anders beginnen? Sie können auch auf „Blank spreadsheet“ klicken, um eigene Daten einzufügen oder einzugeben, oder „Try a sample dataset“ auswählen, um Beispieldaten zu erkunden. Ausführliche Informationen finden Sie unter So fügen Sie Ihre Daten in BioRender Graphing hinzu.

💡 Importieren Sie Daten aus GraphPad Prism? Lesen Sie So importieren Sie Ihre Prism-Dateien in BioRender Graphing. 

Schritt 2: Diagramm erstellen

  1. Bitten Sie den Agenten im Chat um ein Diagramm. Beispiel: „Help me set up a graph from [dataset name].“ Wenn Sie Ihre Daten mit dem Agenten importiert haben, empfiehlt er Ihnen einen Diagrammtyp.
  2. Der Agent schlägt einen zu Ihren Daten passenden Diagrammtyp vor, z. B. eine Dosis-Wirkungs-Kurve. Sagen Sie „Ja“ oder nennen Sie einen anderen Diagrammtyp.
  3. Der Agent teilt Ihnen mit, welche Anforderungen dieses Diagramm hat, z. B. eine numerische X-Achse und eine numerische Y-Achse, und weist Ihre Variablen zu.
  4. Wenn das Diagramm Gruppierungen unterstützt, bietet der Agent Optionen an. Klicken Sie auf eine Option oder geben Sie Ihre eigene ein.
  5. Der Agent zeigt einen Plan an, der das Diagramm zusammenfasst. Klicken Sie auf „Create the graph“.
  6. Der Agent bestätigt, was er erstellt hat, und führt Sie sofort zu Ihrem neuen Diagramm. 

Beispiel: Der Diagramm-Agent schlägt einen Diagrammtyp vor.

Schritt 3: Eine Analyse Run

  1. Geben Sie im Chat „run an analysis“ ein oder nennen Sie die gewünschte Analyse. Der Agent schlägt möglicherweise auch eine Analyse vor, nachdem er Ihr Diagramm erstellt hat.
  2. Der Agent listet die für Ihren Diagrammtyp verfügbaren Analysen auf. Für eine Dosis-Wirkungs-Kurve sind dies:
  • Outlier Detection: markiert Ausreißer in Ihren Daten
  • Area Under Curve: Gesamtfläche unter der Kurve jeder Gruppe
  • Korrelationsanalyse: Stärke und Richtung des Zusammenhangs zwischen zwei numerischen Variablen
  • Lineare Regression: modelliert einen linearen Zusammenhang
  • Nichtlineare Regression: passt Kurven an, z. B. dose-response-Modelle
  1. Der Agent empfiehlt die zu Ihren Daten passende Analyse. Klicken Sie auf einen Vorschlag oder geben Sie die gewünschte Analyse ein.
  2. Folgen Sie den Anweisungen des Agenten, um die Analyse einzurichten.
  3. Überprüfen Sie Ihre Ergebnisse im Tab „Analysis“. Signifikante Vergleiche werden Ihrem Diagramm hinzugefügt.

Beispiel: Der Diagramm-Agent schlägt abhängig von Ihrem Diagrammtyp verfügbare Analysen vor. 

The Agent will set up your analysis for you

Weitere Informationen zu Analysen finden Sie unter Statistische Analysen in BioRender Graphing durchführen.

Schritt 4: Diagramm anpassen

  1. Klicken Sie auf der Seite Graph auf „Ask BioRender“.
  2. Beschreiben Sie die gewünschte Änderung. Benennen Sie den Teil des Diagramms, z. B. eine Gruppe, eine Achse oder die Legende.
  3. Überprüfen Sie das aktualisierte Diagramm.
  4. Wenn Ihnen das Ergebnis nicht gefällt, klicken Sie oben links auf den Rückgängig-Pfeil oder bitten Sie den Agenten, die Aktion rückgängig zu machen. 

Der Agent nimmt Änderungen mit denselben Graphing-Tools innerhalb von BioRender vor, sodass Ihr Diagramm vollständig manuell bearbeitbar bleibt.

Beispiel: Eingabeaufforderung: Färbe die Datenpunkte in Compound B, die auf der x-Achse zwischen 9.899 und 103.1 liegen, rot. Arbeiten mit dem Agenten in der zentralen Chatansicht.

Prompting an edit with the Graphing agent

Alle Möglichkeiten zur Anpassung finden Sie unter So passen Sie Ihr Diagramm an.

Was Sie sagen können: Beispiele für Eingabeaufforderungen

Aktion Beispiel
Diagramm starten „Help me set up a graph from [dataset name].“
Eine Analyse Run „Run an analysis.“
Farben ändern „Make the colors grayscale, except keep compound B in red.“
Eine Farbe ändern „Change the line from purple to pink.“
Form der Datenpunkte ändern „Change all data points to diamond shapes.“
Punkte hervorheben „Make all the data points black that are less than y = 2 or greater than y = 98.“

Tipps für bessere Ergebnisse

  • Seien Sie konkret: Sagen Sie, was Sie wo ändern möchten. Statt „Change the colors“ können Sie beispielsweise sagen: „Make all data series grayscale except Treatment 1, which should be red.“
  • Benennen Sie Ihre Daten: Verwenden Sie die Namen Ihrer Datensätze, Variablen und Gruppen, z. B. „Group by Cell Line“.
  • Nehmen Sie jeweils nur eine Änderung vor: So können Sie das Ergebnis leichter überprüfen und die Änderung rückgängig machen.
  • Verwenden Sie die Vorschlagsschaltflächen: Wenn der Agent Optionen anbietet, klicken Sie auf eine davon, anstatt sie einzugeben.
  • Formulieren Sie die Anfrage neu, wenn das Ergebnis nicht passt: Machen Sie die Änderung rückgängig und beschreiben Sie sie mit anderen Worten.

Jederzeit manuell arbeiten

Sie können jederzeit zwischen dem Chat und dem Arbeiten ohne den Agenten wechseln.

  • Diagramm anpassen: Klicken Sie oben rechts im Tab Graph auf „Customize graph“, um das Diagramm manuell zu bearbeiten.
  • Graph-Details: Klicken Sie im Bereich mit den Graph-Details auf „Edit“, um Datensatz, Variablen oder Gruppierung zu ändern.
  • Neue Analyse Run: Klicken Sie im Bereich „Analysis“ auf „Run new analysis“.
  • Rückgängig und wiederholen: Verwenden Sie die Pfeile oben links.

Fehlerbehebung

Das Feld „Ask BioRender“ wird nicht angezeigt. 

Aktualisieren Sie die Seite und prüfen Sie anschließend, ob Sie sich in einer Graphing-Datei befinden. Wenn es weiterhin fehlt, wenden Sie sich an den Support.

Der Agent hat meine Anweisung nicht ausgeführt. 

Machen Sie die Änderung rückgängig und versuchen Sie es erneut mit einer genaueren Anfrage. Benennen Sie die gemeinte Gruppe, Achse oder die Datenpunkte. Wenn der Agent die gewünschte Aktion nicht ausführen kann, teilt er Ihnen den Grund mit.

Der Agent hat ein Diagramm suggested, das ich nicht möchte. 

Sagen Sie ihm, welchen Diagrammtyp Sie möchten, oder wählen Sie selbst einen im Bereich Graphs im Tab „Data“ aus.

„Run new analysis“ reagiert nicht. 

Sie müssen Ihre Diagrammdetails zuerst bestätigen oder speichern. Prüfen Sie, ob der Bereich mit den Graph-Details noch im Bearbeitungsmodus geöffnet ist, und schließen oder bestätigen Sie ihn.

Meine Datei wurde nicht importiert. 

Prüfen Sie, ob Ihre Datei ein unterstütztes Format hat und kleiner als 50 MB ist. Informationen zu Datenlimits finden Sie unter So fügen Sie Ihre Daten in BioRender Graphing hinzu.


Häufig gestellte Fragen

Benötige ich einen Graphing-Platz, um den Agenten zu verwenden? 

Der Agent ist Bestandteil von BioRender Graphing. 

Verursacht der Agent zusätzliche Kosten? 

Nein. Es fallen keine zusätzlichen Kosten an. 

Verändert der Agent meine Daten?

Nein. Wenn Sie Ihr Diagramm anpassen, ändert sich nur dessen Darstellung. Ihre zugrunde liegenden Daten bleiben unverändert.

Verwendet der Agent meine Daten zum Trainieren von KI-Modellen?

Wenn Sie die agentenbasierten Funktionen von Graphing verwenden, sind Ihre Daten bei BioRender sicher. Der Agent arbeitet über die integrierten Analyse- und Diagrammtools von BioRender. Daher liest oder verändert er Ihre Daten nicht und verwendet sie ohne Ihre Zustimmung niemals zum Trainieren von KI.

Wie mache ich eine Änderung rückgängig? 

Klicken Sie oben links auf den Rückgängig-Pfeil oder bitten Sie den Graphing-Agenten, die Aktion rückgängig zu machen. Verwenden Sie den Wiederholen-Pfeil, um die Änderung wiederherzustellen.

Kann ich mit dem Agenten jede beliebige Analyse durchführen? 

Der Agent bietet die für Ihren Diagrammtyp verfügbaren Analysen an.

Kann ich weiterhin Diagramme ohne den Graphing-Agenten erstellen? 

Ja. Wählen Sie im Bereich „Graphs“ im Tab „Data“ einen Diagrammtyp aus, weisen Sie Ihre Variablen zu und klicken Sie auf „Continue“. Siehe Erste Schritte mit BioRender Graphing.

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

War dieser Beitrag hilfreich?

0 von 0 fanden dies hilfreich