Erste Schritte mit BioRender Graphing Erste Schritte mit BioRender Graphing

Erste Schritte mit BioRender Graphing

BioRender Graphing ist das neue statistische Tool für Grafikerstellung und Analysen von BioRender, das Rohdaten innerhalb weniger Minuten in publikationsfähige Grafiken umwandelt. Es vereint Datenimport, automatische Datenaufbereitung, Grafikerstellung, Ausreißererkennung und statistische Analyse in einem einheitlichen Workflow – verabschieden Sie sich von der manuellen Datenaufbereitung und dem Wechsel zwischen verschiedenen Tools. 

Ziehen Sie Ihre Datendateien per Drag-and-drop hinein, ohne sie zu kopieren und einzufügen, erstellen Sie mehrere Grafiken aus demselben Datensatz, ohne Ihre Daten neu strukturieren zu müssen, und nutzen Sie integrierte Vorabtests, die den passenden statistischen Test empfehlen und erklären, warum. Sie können außerdem Ihre vorhandenen Prism-Dateien importieren – alles sicher in BioRender gespeichert. Dieser Artikel behandelt den vollständigen Ablauf – vom Import Ihrer Daten bis zur Durchführung und Interpretation von Analysen.

Übersicht

So erstellen Sie eine BioRender-Graphing-Datei 

Aus Ihrer Gallery:

  1. Klicken Sie oben links auf „Create New“.
  2. Wählen Sie „Graph“ aus.
  3. Klicken Sie auf „New Graphing“.

4. Erkunden Sie, was Sie erstellen können. Überprüfen Sie im Fenster „Explore what you can create with BioRender Graphing“ die verfügbaren Grafiken und Analysen:

  • Wählen Sie links eine Kategorie aus: Gruppen vergleichen, Beziehungen und Trends, Kurven und Assays, Teile eines Ganzen oder Überleben.
  • Durchsuchen Sie die Grafiken und Analysen für diese Kategorie. Elemente unter „Available now“ können sofort verwendet werden.
  • Sehen Sie sich die Elemente unter „Coming soon“ an, z. B. das Histogramm, den Forest-Plot, die Drei-Wege-ANOVA und die verschachtelte ANOVA.
  • Klicken Sie neben einem Element unter „Coming soon“ auf das Glockensymbol, um benachrichtigt zu werden, sobald es verfügbar ist.
  • Schließen Sie das Fenster (X), wenn Sie fortfahren möchten.

Schritt 1: Daten eingeben

Es gibt zwei Möglichkeiten, Daten in eine BioRender-Graphing-Datei zu übertragen.

  1. Datensatz hochladen (Smart Data Import)
  2. Leere Tabelle

Option 1: Datensatz mit Smart Data Import hochladen

  1. Klicken Sie auf der Registerkarte „Data“ auf „Upload dataset“.
  2. Wählen Sie Ihre Excel-, CSV- oder .prism-Datei aus:
    • Dateien mit mehreren Tabellen zeigen alle verfügbaren Tabellen an – wählen Sie alle aus oder eine einzelne. 
    • Bei .prism-Dateien ist die Option zum Importieren von Grafiken und Analysen standardmäßig aktiviert. Wenn Sie nur die Rohdaten importieren möchten, deaktivieren Sie diese Option.
  3. Wählen Sie die zu importierenden Datensätze aus.
  4. Klicken Sie zur Bestätigung auf „Import data“.
  5. Überprüfen Sie die automatisch erkannten Variablen in der Importvorschau.
  6. Bearbeiten Sie bei Bedarf Variablennamen oder Zuordnungen.
  7. Klicken Sie zur Bestätigung auf „Import Data“.
  8. Überprüfen Sie die automatisch erkannten Variablen in der Importvorschau.
  9. Bearbeiten Sie bei Bedarf Variablennamen oder Zuordnungen.

💡 Importieren Sie Daten aus GraphPad Prism? BioRender unterstützt .prism-Dateien (neuestes Format). Ältere .pzfx-Dateien importieren nur Daten. Die vollständige Anleitung finden Sie hier: Aus GraphPad Prism importieren

Option 2: Leere Tabelle 

  1. Klicken Sie auf der Registerkarte „Data“ auf „Blank spreadsheet“.
  2. Kopieren Sie Ihre Daten und fügen Sie sie ein.
  3. Fügen Sie bei Bedarf Zeilen und Spalten hinzu oder löschen Sie sie, indem Sie mit der rechten Maustaste auf eine beliebige Zelle klicken.

Klicken Sie auf „Re-detect variables“, um Ihren Datensatz zu analysieren – BioRender Graphing verwendet die Schritte von Smart Data Import, um Ihre Variablen automatisch zu erkennen und Sie für die Grafikerstellung vorzubereiten.

Empfehlungen für alle Datensätze

  • Für den Upload: Maximale Dateingröße (alle Dateitypen): 50 MB
  • Für den Upload oder die manuelle Dateneingabe in eine leere Tabelle: Empfohlene Höchstzahl von 5.000 Datenpunkten zum Erstellen von Grafiken und Ausführen von Analysen. Bei größeren Dateien kann die Leistung stark beeinträchtigt sein.

Empfohlene Datenlimits für CSV- oder Excel-Dateien

Halten Sie Ihre Daten für eine optimale Leistung innerhalb dieser Grenzen:

Limit Empfohlener Wert
Maximale Spaltenanzahl 50
Maximale Zeilenanzahl 10.000

Diese Limits gewährleisten:

  • Schnelle Verarbeitungszeiten (unter 10 Sekunden)
  • Kompatibilität mit Funktionen für statistische Analysen
  • Zuverlässige Importe für alle Datentypen

Aufbau von Datensätzen

Jede BioRender-Graphing-Datei ist in drei Registerkarten gegliedert:

  1. Data –  Importieren und Verwalten Ihrer Datensätze
  2. Graph – Grafiken erstellen, anzeigen und anpassen
  3. Analysis – Statistische Analysen Run und überprüfen

Nach dem Import wird jeder Datensatz unten auf der Registerkarte „Data“ als eigene Registerkarte angezeigt.  Sie können zwischen den Datensätzen wechseln, um sie anzuzeigen. Die Variablen des aktiven Datensatzes werden im linken Bereich aufgelistet.

In der Datenansicht können Sie:

  • Variablen, Zeilen oder Spalten manuell hinzufügen oder löschen
  • Variablen umbenennen
  • Sehen, welche Grafiken mit den einzelnen Datensätzen verknüpft sind

Schritt 2: Grafik erstellen

Erste Grafik erstellen

  1. Klicken Sie auf der Registerkarte „Data“ bei einem Datensatz rechts auf die Grafik, die Sie erstellen möchten.

  2. Dadurch gelangen Sie zur Seite für die Graph-Bearbeitung.
  3. Ordnen Sie Ihre Variablen zu – die Grafikvorschau wird in Echtzeit aktualisiert, während Sie die einzelnen Felder ausfüllen.
  4. Wenn die Vorschau korrekt aussieht, klicken Sie auf „Continue“.

Grafik anpassen

Nach dem Klicken auf „Continue“ wird rechts auf dem Bildschirm das Anpassungsfenster geöffnet. 

Settings sind in Abschnitte gegliedert:

Daten anzeigen (zuerst angezeigt – dies ist die am häufigsten benötigte Einstellung)

  • Wählen Sie aus, was dargestellt werden soll: Mittelwert mit Standardabweichung, Mittelwert mit SEM usw.
  • Aktivieren oder deaktivieren Sie „Individuelle Datenpunkte anzeigen“.

Farbe und Schriftart

  • Passen Sie Grafikfarben, Schriftstile und -größen an.

Zusätzliche Einstellungen

  • Greifen Sie auf weitere erweiterte Optionen für Achsenformatierung, Abstände und Linien zu.

💡 Sie müssen Ihre Grafikdetails bestätigen oder speichern, bevor Sie eine neue statistische Analyse ausführen oder Ihre Grafik anpassen können. Wenn die Schaltfläche „Analyse Run“ nicht reagiert, prüfen Sie, ob das Fenster mit den Grafikdetails noch im Bearbeitungsmodus geöffnet ist – schließen oder bestätigen Sie es zuerst. 

Mit BioRender AI anpassen (Beta)

Sie können Ihre Grafik mithilfe von BioRender AI im Chatfeld für die Schnellbearbeitung anpassen. Beschreiben Sie einfach die gewünschten Änderungen, z. B. die Aktualisierung von Farben, Beschriftungen, Achsen oder Datenpunktstilen, und BioRender AI wendet sie für Sie an. Ihre zugrunde liegenden Daten bleiben unverändert, und Sie können jederzeit manuell weiterbearbeiten oder Änderungen rückgängig machen. Weitere Informationen finden Sie unter Grafiken mit BioRender AI anpassen (Beta).

Beispiel: „Bei allen Datenpunkten mit einer Aktivität von mehr als 98 % oder weniger als 2 % die Füllung rot machen“

 

Grafikdetails nach der Grafikerstellung bearbeiten

Graph-Details (Typ, Variablen, Datensatz) können jederzeit erneut geöffnet und bearbeitet werden. Wenn Sie die Grafikdetails im Bearbeitungsmodus erneut öffnen, werden Sie gefragt, ob Sie nicht gespeicherte Änderungen beibehalten oder verwerfen möchten, bevor Sie die Änderungen bestätigen.

Schritt 3: Ausreißererkennung überprüfen

Die Ausreißererkennung wird automatisch für jede Grafik ausgeführt – Sie müssen sie nicht manuell starten. BioRender verwendet für die Ausreißererkennung die ROUT-Methode (Robuste regression und Ausreißerentfernung). 

Das wird angezeigt

  • Die Anzahl der erkannten Ausreißer wird im linken Bereich angezeigt.
  • Ausreißer werden automatisch erkannt und in der Datentabelle unterhalb der Grafik hervorgehoben.
  • Klicken Sie auf den Ausreißerbericht, um den vollständigen Bericht zu öffnen. Dieser zeigt:
    • Gesamtzahl der analysierten Datenpunkte
    • Anzahl der erkannten Ausreißer
    • Aufschlüsselung der Ausreißer nach Gruppe

Empfindlichkeit mit dem Q-Parameter anpassen

Wenn Sie ändern möchten, wie streng Ausreißer identifiziert werden, können Sie den Q-Parameter anpassen:

  1. Öffnen Sie den Ausreißerbericht.
  2. Klicken Sie auf „Update settings“.
  3. Geben Sie einen Q-Wert zwischen 0,1 und 10 ein:
    • Niedrigere Werte = strenger (weniger markierte Ausreißer)
    • Höhere Werte = weniger streng (mehr markierte Ausreißer)
  4. Klicken Sie auf „Rerun“, um den aktualisierten Schwellenwert anzuwenden und die überarbeiteten Ergebnisse anzuzeigen.

Tipp: Dies ist hilfreich, wenn Sie testen möchten, wie eindeutig ein bestimmter Ausreißer ist – beispielsweise um zu bestätigen, ob ein Datenpunkt definitiv ein Ausreißer oder nur grenzwertig ist.

Datenpunkte ausschließen

Für den Umgang mit Ausreißern und anderen Datenpunkten, die Sie ausschließen möchten, gibt es zwei Möglichkeiten:

  1. Einzelne Datenpunkte ausschließen: Klicken Sie mit der rechten Maustaste auf einen beliebigen Datenpunkt – auch auf Nicht-Ausreißer –, um ihn manuell auszuschließen. 
  2. Alle erkannten Ausreißer gleichzeitig ausschließen: Aktivieren oder deaktivieren Sie im Ausreißerbericht das Kontrollkästchen „Exclude all outliers“, um alle Ausreißer mit einem Klick ein- oder auszuschließen. Aktivieren oder deaktivieren Sie diese Option, um Ergebnisse zu vergleichen.

Weitere Informationen finden Sie unter Ausreißererkennung verstehen (ROUT-Methode).

Schritt 4: Statistische Analyse Run

Analyse starten

  1. Klicken Sie auf der Seite für die Graph-Bearbeitung auf „Run analysis“.
  2. Ein strukturiertes Formular mit drei Abschnitten wird angezeigt:
Abschnitt 1 – Anal thetyp 

Wenn möglich, empfiehlt die Analysehilfe von BioRender Graphing automatisch den am besten geeigneten statistischen Test auf Grundlage Ihrer Daten. Der empfohlene Test ist mit einem Abzeichen gekennzeichnet.

  • Sie können die Empfehlung überschreiben, indem Sie das Dropdown-Menü öffnen, um alle verfügbaren Optionen anzuzeigen.
  • Wenn Sie einen Test auswählen, der nicht zu den Annahmen Ihrer Daten passt (z. B. einen parametrischen Test, obwohl die Daten nicht normalverteilt sind), erklärt eine Warnung, warum der empfohlene Test weiterhin vorzuziehen ist.
  • Einige Tests werden möglicherweise ausgegraut angezeigt, wenn Ihre Daten die Anforderungen nicht erfüllen. Informationen dazu finden Sie im Tooltip.
Kategorische Gruppen auswählen
  • Standardmäßig sind alle Gruppen aus der Grafik eingeschlossen.
  • Deaktivieren Sie die Auswahl aller Gruppen, die Sie nicht in diese Analyse einbeziehen möchten. 
Abschnitt 2 – Analyse optimieren

In diesem Abschnitt können Sie statistische Einstellungen für Ihre Analyse anpassen. Die verfügbaren Optionen können je nach ausgewähltem Analysetyp variieren. BioRender empfiehlt Einstellungen auf Grundlage der für Ihre Daten durchgeführten Vorabtests, Sie können diese bei Bedarf jedoch ändern.

  • Datenaufbau: Legen Sie fest, wie Ihre Daten für die Analyse organisiert sind. Die verfügbaren Optionen hängen von der ausgewählten Methode ab.
  • Erweiterte Optionen: Erweitern Sie diesen Abschnitt, um zusätzliche Konfigurationseinstellungen aufzurufen, sofern verfügbar.
  • Annahmen: Einige Analysen enthalten konfigurierbare Annahmen zu Ihren Daten. Sofern zutreffend, können Sie diese Einstellungen überprüfen und anpassen.

Beispiel (verfügbare Optionen können variieren)

Abschnitt 3 – Options und zusätzliche Einstellungen

Einige Analysen enthalten zusätzliche Optionen, mit denen Sie anpassen können, wie Ergebnisse verglichen und berechnet werden. Diese Einstellungen werden nur angezeigt, wenn sie für die ausgewählte Analyse relevant sind, und empfohlene Optionen werden automatisch angewendet.

  • Vergleiche: Wählen Sie gegebenenfalls aus, wie Gruppen oder Bedingungen verglichen werden. Dazu kann der Vergleich aller Gruppen oder die Auswahl bestimmter Vergleiche gehören.
  • Folgetest: Einige Analysen enthalten optionale Folgetests, um Unterschiede zwischen Gruppen zu untersuchen. Sie können eine Methode auswählen oder die empfohlene Option verwenden.
  • Automatische Empfehlungen: BioRender schlägt auf Grundlage Ihres Analysetyps und Ihrer Daten geeignete Einstellungen vor. Bei Bedarf können Sie diese anpassen.

Beispiel (verfügbare Optionen können variieren) 

Ergebnisse anzeigen

Nach der Durchführung der Analyse:

  • Eine vollständige Ergebnistabelle und deskriptive Statistiken werden im Bereich „Analysis“ angezeigt.
  • Signifikante Vergleiche werden automatisch mit Signifikanzmarkierungen zur Grafik hinzugefügt.
  • Verwenden Sie die Kontrollkästchen im Graph-Bereich, um festzulegen, welche Ergebnisse in der Grafik angezeigt werden.
  • Sie können mehrere Analysen für dieselbe Grafik durchführen und steuern, welche davon angezeigt werden.

Beispiel für den Bereich „Analysis“ auf der Registerkarte Graph:


Mehrere Grafiken verwalten: Ansicht Graph Grid

Wenn Ihre Datei wächst, können Sie die Ansicht Graph Grid (Registerkarte Graph) verwenden, um alle Grafiken der Datei auf einen Blick zu sehen.

In der Ansicht navigieren

  • Nach einer Grafik anhand ihres Namens suchen
  • Nach Datensatz filtern, um die Grafiken einer bestimmten Datentabelle anzuzeigen
  • Nach Name, Erstellungsdatum oder letzter Änderung sortieren

Hinweis: Die Ansicht Graph Grid zeigt nur die Grafiken innerhalb der aktuellen Datei. Grafiken aus anderen Dateien werden hier nicht angezeigt.

Massenaktionen

Wählen Sie eine oder mehrere Grafiken aus, um auf Massenaktionen zuzugreifen:

  • Duplizieren – Nützlich, um eine Variante einer vorhandenen Grafik zu erstellen (z. B. von einem Balkendiagramm zu einem Boxplot zu wechseln oder eine Variable anzupassen)
  • Stil übernehmen – Den Stil einer Grafik kopieren und auf andere anwenden (siehe unten)
  • Löschen

Stil übernehmen

Erstellen Sie mit Style Match mit wenigen Klicks visuell einheitliche Grafiken – einschließlich Schriftarten, Farben, Achsenformatierung, Abständen und mehr. Der Stil einer Grafik kann vollständig aus der Ansicht Graph Grid übernommen werden, ohne einzelne Grafiken zu öffnen.

So verwenden Sie die Funktion:

  1. Wählen Sie in der Ansicht Graph Grid oder in Ihrer Einzelgrafik die Grafik aus, deren Stil Sie kopieren möchten.
  2. Klicken Sie auf „Stil übernehmen“ → „Copy style“.
  3. Wählen Sie eine oder mehrere Zielgrafiken aus.
  4. Klicken Sie auf „Paste style“.
  5. Die ausgewählten Grafiken übernehmen den Stil der ursprünglich ausgewählten Grafik.

Beim Kopieren eines Stils können Sie auswählen, welche Kategorien angewendet werden sollen:

  • Graph-Stil (standardmäßig aktiviert):  Farben, Abstände, Linien, Schriftarten 
  • Statistische Markierungen  (standardmäßig aktiviert): Paarweise Vergleiche, Best-Fit-Linien 
  • Größe und Abmessungen der Graph:  Nützlich für einheitliche Panelabbildungen
  • Achsbereich und Skalierung: Nützlich, wenn Sie eine logarithmische Skala oder benutzerdefinierte Teilstrichabstände festgelegt haben

Eine vollständige Anleitung zur Verwendung von Style Match finden Sie in diesem Artikel: So kopieren Sie den Stil einer Grafik mit Style Match in BioRender Graphing


Grafiken und Analysen exportieren

So exportieren Sie Ihre Grafik

  1. Öffnen Sie die zu exportierende Grafik in der Registerkarte Graphing.
    • Stellen Sie sicher, dass Sie sich in der richtigen Registerkarte befinden (Data, Graph, Analysis). Die von Ihnen ausgewählte Registerkarte wird exportiert.
  2. Klicken Sie oben rechts auf Ihrer BioRender-Seite auf die blaue Schaltfläche „Export“.
  3. Wählen Sie den gewünschten Dateityp und die Auflösung aus.
  4. Klicken Sie auf „Export“, um Ihre Grafik herunterzuladen.

So exportieren Sie Ihre Analysen

  1. Öffnen Sie die zu exportierende Analyse in der Registerkarte Analysis.
  2. Klicken Sie oben rechts auf Ihrer BioRender-Seite auf die blaue Schaltfläche „Export“.
  3. Wählen Sie die gewünschte zu exportierende Analyse aus.
  4. Klicken Sie auf „Export“, um Ihre Analyse als .csv- oder PDF-Datei herunterzuladen.

❗Wichtiger Hinweis: Wenn Sie Ihre Grafik in einer anderen Anwendung bearbeiten müssen, exportieren Sie sie als SVG-Datei. Anschließend können Sie sie in Vektorbearbeitungsprogrammen wie Adobe Illustrator, Affinity Designer und anderen bearbeiten.


Aus GraphPad Prism importieren

Wenn Sie bereits über Prism-Dateien verfügen, können Sie diese direkt in BioRender Graphing importieren – einschließlich Daten, Grafiken und Analysen.

Unterstütztes Dateiformat

  • BioRender unterstützt das .prism-Dateiformat (das neueste Prism-Format).
  • Ältere .pzfx-Dateien werden teilweise unterstützt – Daten werden importiert, Grafiken und Analysen jedoch nicht.
  • Um eine .pzfx-Datei mit intakten Grafiken und Analysen zu importieren, speichern Sie sie zunächst in GraphPad Prism erneut als .prism-Datei und importieren Sie sie anschließend.

So importieren Sie Daten

  1. Klicken Sie auf der Registerkarte „Data“ auf „Upload dataset“ und wählen Sie Ihre .prism-Datei aus.
  2. Alle Datensätze aus der Datei werden angezeigt – wählen Sie alle oder bestimmte Datensätze aus.
  3. Die Option zum Importieren von Grafiken und Analysen ist standardmäßig aktiviert. Wenn Sie nur die Rohdaten importieren möchten, deaktivieren Sie diese Option.
  4. Klicken Sie auf „Import“.

Weitere Informationen zum Importieren Ihrer .prism-Dateien finden Sie in diesem Artikel.


Grafiken zu einer Illustration hinzufügen

Sie können BioRender-Graphing-Dateien direkt in Ihren BioRender-Illustrationsdateien verwenden.

  1. Im Illustrationseditor: Verwenden Sie das Grafikeinfügefenster im Editor, um Grafiken aus Ihren BioRender-Graphing -Dateien zu durchsuchen und einzufügen. Sobald sich die Grafik auf der Arbeitsfläche befindet, können Sie einzelne Grafikelemente anklicken und direkt formatieren.
  2. In der Ansicht Graph Grid – Wählen Sie eine oder mehrere Grafiken aus und verwenden Sie „Add to illustration“, um sie an eine vorhandene Illustrationsdatei zu übertragen. In einem Dialogfeld können Sie auswählen, an welche Datei sie gesendet werden sollen.

Benötigen Sie Hilfe? Wenden Sie sich unter support@biorender.com an unser Supportteam oder starten Sie einen Livechat, indem Sie unten rechts auf die Blase „Chat With Us“ klicken.

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

War dieser Beitrag hilfreich?

4 von 8 fanden dies hilfreich