BioRender Graphingを始める

BioRender Graphingは、BioRenderの新しい統計グラフ作成・分析ツールです。生データを数分で出版品質のグラフに変換できます。データのインポート、自動データ準備、グラフ作成、外れ値検出、統計分析を、1つの統合されたワークフローにまとめています。手作業でのデータ準備やツールの切り替えはもう必要ありません。

コピー&ペーストせずにデータファイルをドラッグ&ドロップし、データを再構成せずに同じデータセットから複数のグラフを作成できます。また、適切な統計検定を推奨し、その理由を説明する組み込みの事前検定も利用できます。既存のPrismファイルをインポートして、すべてをBioRenderに安全に保存することもできます。この記事では、データのインポートから分析の実行・解釈まで、最初から最後までの操作方法を説明します。

概要

BioRender Graphingファイルを作成する方法

Galleryから:

  1. 左上隅の「Create New」をクリックします。
  2. 「Graph」を選択します。
  3. 「New Graphing」をクリックします。

BioRender Graphingファイルは、3つのタブで構成されています。

  1. Data - データセットをインポートおよび管理します
  2. Graph - グラフを作成、表示、カスタマイズします
  3. Analysis - 統計分析をRunし、結果を確認します

ステップ1:データをEnterする

BioRender Graphingファイルにデータを取り込む方法は2つあります。

  1. データセットをUploadする(Smart Data Import)
  2. 空白のスプレッドシート

オプション1:Smart Data ImportでデータセットをUploadする

  1. Dataタブで、"Upload dataset"をクリックします。
  2. Excel、CSV、または.prismファイルを選択します。
    • 複数のシートを含むファイルでは、利用可能なすべてのシートが表示されます。すべてを選択するか、1つを選択します。
    • .prismファイルでは、グラフと分析をインポートするオプションがデフォルトで有効になっています。生データのみが必要な場合は、このオプションの選択を解除します。
  3. インポートするデータセットを選択します。
  4. 「Import data」をクリックして確定します。
  5. インポートプレビューで自動検出された変数を確認します。
  6. 必要に応じて、変数名または割り当てを編集します。
  7. 「Import Data」をクリックして確定します。

  8. インポートプレビューで自動検出された変数を確認します。
  9. 必要に応じて、変数名または割り当てを編集します。

💡 GraphPad Prismからインポートしますか?BioRenderは.prismファイル(最新形式)に対応しています。古い.pzfxファイルはデータのみインポートされます。詳しいガイドについては、こちらをご覧ください:GraphPad Prismからのインポート

オプション2:Blank spreadsheet

  1. DataタブでBlank spreadsheetをクリックします。
  2. データをコピーして貼り付けます。
  3. 任意のセルを右クリックし、必要に応じて行や列を追加または削除します。

Re-detect variablesをクリックしてデータセットを分析します。BioRender GraphingはSmart Data Importの手順を使用して変数を自動検出し、グラフ作成の準備を整えます。

すべてのデータセットに関する推奨事項

  • アップロード:Fileサイズの上限(すべてのファイル形式):50 MB
  • 空白のスプレッドシートへのアップロードまたは手動入力:グラフ作成と分析の実行には、最大5,000データポイントをRecommendedします。これを超えるファイルではパフォーマンスが大幅に低下する可能性があります。

Recommended CSVまたはExcelファイルのデータ上限

最適なパフォーマンスを得るには、データを次の上限内に収めてください。

上限 Recommended値
最大列数 50
最大行数 10,000

これらの上限により、次のことが実現します。

  • 高速な処理時間(10秒未満)
  • 統計分析機能との互換性
  • すべてのデータ形式で信頼性の高いインポート

データセットの構成

インポートすると、各データセットがDataタブ下部のタブとして表示されます。タブをクリックしてデータセットを切り替え、表示できます。アクティブなデータセットの変数は左側のパネルに表示されます。

データビューでは、次の操作ができます。

  • 変数、行、列を手動で追加または削除する
  • 変数のRenameを行う
  • 各データセットにリンクされているグラフを確認する

ステップ2:グラフを作成する

最初のグラフを作成する

  1. Dataタブのデータセットから、「Create new graph」をクリックします。
  2. Graph編集ページが表示されます。
  3. グラフの種類(棒グラフ、縦棒グラフ、散布図、平均値/中央値線など)を選択します。
  4. 変数を割り当てます。各フィールドに入力すると、グラフのプレビューがリアルタイムで更新されます。
  5. プレビューが適切になったら、「Continue」をクリックします。

グラフをカスタマイズする

「Continue」をクリックすると、画面右側にカスタマイズパネルが開きます。

Settingsはセクションごとに整理されています。

データの表示(最初に表示される、最もよく使用する設定)

  • プロットする内容を選択します:標準偏差付き平均、SEM付き平均など。
  • 個々のデータポイントの表示をオンまたはオフにします。

Colorとフォント

  • グラフの色、フォントスタイル、サイズを調整します。

追加設定

  • 軸の書式、間隔、線に関する高度なオプションにアクセスします。

💡 新しい統計分析を実行したり、グラフをカスタマイズしたりする前に、グラフの詳細を確定または保存する必要があります。Run Analysisボタンが反応しない場合は、グラフの詳細パネルが編集モードのまま開いていないか確認してください。まずパネルを閉じるか、確定してください。

グラフ作成後にグラフの詳細を編集する

Graphの詳細(種類、変数、データセット)は、いつでも再度開いて編集できます。グラフの詳細を編集モードで再度開くと、変更を確定する前に、保存していない編集内容を保持するか破棄するかを尋ねるメッセージが表示されます。

ステップ3:外れ値検出を確認する

外れ値検出はすべてのグラフで自動的に実行されるため、手動で実行する必要はありません。BioRenderは外れ値の検出にROUT(Robust regression and Outlier removal)法を使用します。

表示される内容

  • 検出された外れ値の数が左側のパネルに表示されます。
  • 外れ値は自動的に検出され、グラフ下のデータテーブルで強調表示されます。
  • 外れ値レポートをクリックすると、次の内容を示す完全な外れ値レポートが開きます。
    • 分析されたデータポイントの総数
    • 検出された外れ値の数
    • グループ別の外れ値の内訳

Qパラメーターで感度を調整する

外れ値をどの程度厳密に識別するかを変更したい場合は、Qパラメーターを調整できます。

  1. 外れ値レポートを開きます。
  2. 「Update settings」をクリックします。
  3. 0.1~10のQ値をEnterします。
    • 値が小さい = より厳格(フラグが付く外れ値が少ない)
    • 値が大きい = より寛容(フラグが付く外れ値が多い)
  4. 「Rerun」をクリックして更新したしきい値を適用し、結果を再表示します。

ヒント:これは、特定の外れ値がどの程度境界的なものかを確認したい場合に役立ちます。たとえば、データポイントが明確な外れ値なのか、境界付近にあるだけなのかを確認できます。

データポイントを除外する

外れ値や、除外したいその他のデータポイントを処理する方法は2つあります。

  1. 個々のデータポイントを除外する:外れ値でないデータポイントを含め、任意のデータポイントを右クリックして手動で除外します。
  2. 検出されたすべての外れ値を一度に除外する:外れ値レポートの「Exclude all outliers」チェックボックスを使用すると、1回のクリックですべての外れ値を除外または除外解除できます。オンとオフを切り替えて結果を比較します。

ステップ4:統計分析をRunする

分析を開始する

  1. Graph編集ページで、Run analysisをクリックします。
  2. 3つのセクションからなるフォームが表示されます。
セクション1 - 分析タイプ

可能な場合、BioRender Graphingの分析ガイダンスは、データに基づいて最も適切な統計検定を自動的に推奨します。推奨検定にはバッジが表示されます。

  • ドロップダウンを開いて利用可能なすべてのオプションを表示し、推奨を上書きできます。
  • データの前提条件に適合しない検定を選択した場合(たとえば、データが正規分布でないのにパラメトリック検定を選択した場合)、推奨検定が適している理由を警告として説明します。
  • データが要件を満たしていない場合、一部の検定はグレー表示されます。理由を確認するには、ツールチップを確認してください。
カテゴリグループを選択する
  • デフォルトでは、グラフのすべてのグループが含まれます。
  • この分析に含めないグループの選択を解除します。
セクション2 - 分析を微調整する

このセクションでは、分析の統計設定を調整できます。利用可能なオプションは、選択した分析の種類によって異なる場合があります。BioRenderは、データに対して実行した事前検定に基づいて設定を推奨しますが、必要に応じて変更できます。

  • データ設定:分析のためにデータをどのように構成するかを定義します。利用可能なオプションは、選択した方法によって異なります。
  • 詳細オプション:このセクションを展開すると、利用可能な追加設定にアクセスできます。
  • 前提条件:一部の分析には、データに関する設定可能な前提条件が含まれます。該当する場合は、これらの設定を確認・調整できます。

例(利用可能なオプションは異なる場合があります)

セクション3 - Optionsと追加設定

一部の分析には、結果の比較方法や計算方法を調整できる追加オプションがあります。これらの設定は、選択した分析に関連する場合にのみ表示され、推奨オプションが自動的に適用されます。

  • 比較:該当する場合、グループまたは条件の比較方法を選択します。すべてのグループを比較するか、特定の比較を選択できます。
  • フォローアップ検定:一部の分析には、グループ間の差を調べるための任意のフォローアップ検定が含まれます。方法を選択するか、推奨オプションを使用できます。
  • 自動推奨:BioRenderは、分析の種類とデータに基づいて適切な設定を提案しますが、必要に応じて調整できます。

例(利用可能なオプションは異なる場合があります)

結果を表示する

分析が実行されると、次のようになります。

  • 完全な結果テーブルと記述統計がAnalysisパネルに表示されます。
  • 有意な比較が有意差マーカー付きで自動的にグラフに追加されます。
  • Graphパネルのチェックボックスを使用して、グラフに表示する結果を切り替えます。
  • 同じグラフで複数の分析を実行し、表示する分析を指定できます。

GraphタブのAnalysisパネルの例:


複数のグラフを管理する:Graph Grid View

ファイルが大きくなったら、Graph Grid View(Graphタブ)を使用して、ファイル内のすべてのグラフを一覧で確認できます。

ビューを操作する

  • グラフ名で検索する
  • データセットでフィルタリングし、特定のデータテーブルのグラフに絞り込む
  • 名前、作成日、または最終更新日でSort byする

注:Graph Grid Viewには、現在のファイル内のグラフのみが表示されます。他のファイルのグラフは表示されません。

一括操作

1つ以上のグラフを選択すると、一括操作を利用できます。

  • 複製 - 既存のグラフのバリエーションを作成する場合に便利です(棒グラフから箱ひげ図への変更や、1つの変数の調整など)
  • スタイルの一致 - 1つのグラフのスタイルをコピーして、他のグラフに適用します(下記参照)
  • 削除

スタイルの一致

Style Matchを数回クリックするだけで使用し、フォント、色、軸の書式、間隔など、グラフの見た目を統一できます。グラフのスタイルの適用は、個々のグラフを開かずに、Graph Grid Viewからすべて行えます。

使用方法:

  1. Graph Grid Viewまたは個々のグラフで、スタイルのコピー元にするグラフを選択します。
  2. 「Style match」→Copy styleをクリックします。
  3. 1つ以上の対象グラフを選択します。
  4. Paste styleをクリックします。
  5. 選択したグラフに、最初に選択したグラフのスタイルが適用されます。

スタイルをコピーするときは、適用するカテゴリを選択できます。

  • Graphのスタイル(デフォルトで選択):色、間隔、線、フォント
  • 統計マーカー(デフォルトで選択):ペアワイズ比較、最適近似線
  • Graphのサイズと寸法:パネル図の一貫性を保つのに便利
  • 軸の範囲とスケール:対数スケールまたはカスタム目盛り間隔を設定した場合に便利

Style Matchの使用方法について詳しくは、こちらの記事をご覧ください:BioRender GraphingでStyle Matchを使用してグラフのスタイルをコピーする方法


グラフと分析をエクスポートする

グラフをエクスポートする方法

  1. Graphingタブで、エクスポートするグラフを開きます。
  2. BioRenderページ右上にある青色の"Export"ボタンをクリックします。
  3. 希望するファイル形式と解像度を選択します。
  4. "Export"をクリックしてグラフをダウンロードします。

分析をエクスポートする方法

  1. Analysisタブで、エクスポートする分析を開きます。
  2. BioRenderページ右上にある青色の"Export"ボタンをクリックします。
  3. エクスポートする分析を選択します。
  4. "Export"をクリックして、分析を.csvファイルまたはPDFファイルとしてダウンロードします。

❗重要:別のアプリケーションでグラフを編集する必要がある場合は、グラフをSVGファイルとしてエクスポートしてください。Adobe Illustrator、Affinity Designerなどのベクター編集ツールで編集できるようになります。


GraphPad Prismからインポートする

既存のPrismファイルがある場合は、データ、グラフ、分析を含めて、BioRender Graphingに直接インポートできます。

対応ファイル形式

  • BioRenderは.prismファイル形式(最新のPrism形式)に対応しています。
  • 古い.pzfxファイルは部分的に対応しています。データはインポートされますが、グラフと分析はインポートされません。
  • グラフと分析を保持したまま.pzfxファイルをインポートするには、まずGraphPad Prismで.prismファイルとして再保存してからインポートします。

インポート方法

  1. DataタブでUpload datasetをクリックし、.prismファイルを選択します。
  2. ファイル内のすべてのデータセットが表示されます。すべてを選択するか、特定のデータセットを選択します。
  3. グラフと分析をインポートするオプションはデフォルトで有効になっています。生データのみが必要な場合は、このオプションの選択を解除します。
  4. Importをクリックします。

.prismファイルのインポートについて詳しくは、 こちらの記事をご覧ください。


イラストにグラフを追加する

BioRender GraphingファイルをBioRenderのイラストファイルで直接使用できます。

  1. イラストエディターから:エディター内のグラフ挿入パネルを使用して、BioRender Graphingファイルからグラフを参照して挿入します。キャンバス上で個々のグラフ要素をクリックすると、インラインでスタイルを設定できます。
  2. Graph Grid Viewから(近日公開)- 1つ以上のグラフを選択し、「Add to illustration」を使用して既存のイラストファイルに追加します。表示されるモーダルで、送信先のファイルを選択できます。

注:Galleryからファイルを選択するときは、緑色のグラフアイコンを探してBioRender Graphingファイルを識別してください。Graph(Classic)ファイルには灰色のアイコンが表示されます。

Screenshot 2026-04-22 at 10.59.10 AM.png

サポートが必要ですか? support@biorender.comまでサポートチームにお問い合わせいただくか、右下隅の"Chat With Us"バブルをクリックしてライブチャットを開始してください。

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

この記事は役に立ちましたか?

8人中4人がこの記事が役に立ったと言っています