Créer des Heatmaps et des Well Plate Heatmaps dans BioRender Graphing Créer des Heatmaps et des Well Plate Heatmaps dans BioRender Graphing

Créer des Heatmaps et des Well Plate Heatmaps dans BioRender Graphing

Si vous travaillez avec des données qui capturent des modèles, des intensités ou des variations dans une structure en forme de grille, comme des relevés de température, des niveaux d’expression génique ou des essais sur plaque à puits, une heatmap peut être un excellent moyen de visualiser vos données. Les well plate heatmaps et les heatmaps vous permettent d’identifier rapidement les tendances et les valeurs aberrantes en utilisant des couleurs pour représenter les valeurs, ce qui facilite l’interprétation et la communication de vos résultats. Voici comment les créer dans BioRender Graphing.

📌 Bêta : L’agent Graphing est en version bêta. 

Avant de commencer

BioRender Graphing propose deux options de heatmap :

  1. Heatmaps classiques : polyvalentes, elles peuvent être utilisées pour différents jeux de données.
  2. Well plate heatmaps : spécialement conçues pour les données provenant de plaques à puits, chaque cellule représentant une ligne et une colonne de la plaque.

Quelle que soit la manière dont vous créez votre heatmap :

  • Chaque valeur du jeu de données correspond à la même position sur la heatmap (par exemple, la ligne 1, colonne 1 se trouve dans le coin supérieur gauche).
  • Vous pouvez coller directement vos propres données dans le jeu de données.
  • Smart Data Import organise vos données pour vous.

Choisissez comment créer votre heatmap

  1. Avec l’agent Graphing : importez vos données et décrivez la heatmap souhaitée.
  2. Manuellement : choisissez une heatmap dans le panneau Graphs et attribuez vous-même vos variables.

Vous pouvez passer de l’une à l’autre à tout moment.

Avec l’agent Graphing

Étape 1 : Ajouter vos données

  1. Ouvrez un nouveau fichier Graphing.
  2. Cliquez sur « Upload data » dans le message de l’agent, ou cliquez sur le bouton « + » dans la zone de discussion.
  3. Choisissez votre fichier, sélectionnez les jeux de données souhaités, puis cliquez sur « Import data ».
  4. L’agent décrit vos données et met en évidence les variables qu’il a détectées.

Import your data

Voir Comment ajouter vos données dans BioRender Graphing.

Étape 2 : Demander une heatmap

Dans la discussion, demandez la heatmap souhaitée. Par exemple : « Create a well plate heatmap from [dataset name]. » L’agent suggère un type de graphique adapté à vos données. Dites oui ou confirmez que vous souhaitez un autre type de graphique. 

ask for a heatmap

Étape 3 : Vérifier vos variables et créer le graphique

L’agent vous indique ce dont le graphique a besoin et attribue vos variables. Vérifiez que « Row factor » et « Column factor » correspondent à vos identifiants de ligne et de colonne. S’il ne peut pas déterminer quelle variable vous voulez dire, il vous le demande. Cliquez sur « Create the graph » lorsque le plan vous convient. 

Check your variables and create your graph

Étape 4 : Personnaliser votre heatmap

Cliquez sur « Ask BioRender » et décrivez la modification souhaitée. Par exemple : « Change the color of the heatmap from blue to red. » 

  • Nommez l’élément que vous souhaitez personnaliser, comme « the color bar » ou « the row labels ». Notez que vous ne pouvez pas cliquer sur un élément du graphique et l’envoyer dans la discussion.
  • Si une modification ne vous convient pas, cliquez sur la flèche d’annulation dans le coin supérieur gauche ou demandez à l’agent d’annuler l’action.
  • Si l’agent ne peut pas effectuer une action, il vous indique ce qu’il n’a pas pu faire. Reformulez votre demande ou effectuez la modification manuellement dans le panneau « Customize Graph ». 

Customize your heatmap

Pour en savoir plus sur l’agent, consultez Comment utiliser l’agent Graphing dans BioRender Graphing (bêta).


Manuellement

Étape 1 : Ajouter vos données

Cliquez sur « Blank spreadsheet » dans l’onglet « Data », puis collez ou saisissez vos données.

Étape 2 : Sélectionner Heatmap ou Well plate heatmap

Cliquez sur « Create New » et ouvrez le menu Graph. Choisissez « Heatmap » ou « Well plate heatmap ».

Étape 3 : Ajouter vos variables

Spécifiez les variables pour « Row factor », « Column factor » et « Values ». Les facteurs de ligne et de colonne doivent être définis sur les variables contenant vos identifiants de ligne et de colonne. Attribuez chaque variable dans le panneau des détails du Graph. Cliquez sur « Continue » lorsque l’aperçu vous convient.

Étape 4 : Personnaliser votre well plate ou votre heatmap

Vous pouvez personnaliser de nombreux éléments de la heatmap, comme pour les autres visualisations BioRender Graphing, notamment la police, le titre du graphique et les étiquettes des axes.

Cliquez sur « Customize graph » dans le coin supérieur droit de l’onglet Graph, ou cliquez sur la partie du graphique que vous souhaitez modifier. Vous pouvez personnaliser :

  • Axe indépendant
  • Axe dépendant
  • Légende
  • Titre du Graph
  • Données d’exemple

Pour les heatmaps et les well plate heatmaps :

  • Normalisation des données : appliquez une mise à l’échelle par ligne ou par colonne. Cela effectue une standardisation en score Z par ligne ou par colonne. Les étiquettes de valeur, les couleurs des éléments et la barre de couleurs s’ajustent automatiquement pour refléter les modifications.
  • Personnalisation de la barre de couleurs : cliquez sur la barre de couleurs pour ouvrir le menu de personnalisation, dans lequel vous pouvez modifier sa position sur le graphique et ajuster la bordure et l’arrière-plan.

Pour les heatmaps uniquement :

  • Forme de la heatmap : la forme par défaut est carrée. Augmentez le rayon des coins pour arrondir les angles.
  • Espacement et marge : ajustez l’espacement entre les cellules et la marge entre les étiquettes de ligne et de colonne et les cellules. Définir l’espacement sur 0 supprime les espaces entre les points de données. La marge ajoute un espace supplémentaire.

Pour les well plate heatmaps uniquement :

  • Bordure de la plaque à puits : les coins arrondis sont utilisés par défaut. Cliquez n’importe où sur la heatmap pour ajuster les paramètres de bordure.
  • Personnalisation de l’affichage des puits : ajustez l’espace entre les puits, la largeur de la bordure et sa couleur en fonction de votre visualisation.
  • Marge et remplissage : la marge ajuste l’espace entre les étiquettes de ligne et de colonne et la plaque. Le remplissage agit sur l’espace entre les puits et le bord de la plaque.

Pour connaître toutes les options de personnalisation, consultez Comment personnaliser votre graphique.

Conseils de dépannage

Des puits sont vides dans votre well plate heatmap ? 

Si vous souhaitez afficher des puits vides avec vos données, veillez à saisir les noms de ligne et de colonne de ces puits. Si les étiquettes sont laissées vides, la heatmap peut sembler incomplète.

Vous avez besoin d’options de clustering ou d’analyse ? 

Nous travaillons activement sur ces fonctionnalités. Restez à l’écoute ! L’agent n’exécute que les analyses prises en charge par Graphing ; il ne peut donc pas encore effectuer de clustering. 

Vous souhaitez changer de type de heatmap ? 

Vous pouvez passer des heatmaps classiques aux well plate heatmaps, et inversement, depuis le menu déroulant. Gardez à l’esprit que toutes les personnalisations ne sont pas conservées ; vous devrez donc peut-être ajuster certains paramètres après le changement. Nous vous recommandons de dupliquer votre graphique avant d’essayer un autre type de visualisation.

L’agent n’a pas créé la heatmap que j’ai demandée. 

Indiquez-lui le type de heatmap souhaité ou choisissez-en une vous-même dans le panneau « Graphs » de l’onglet Data.

Besoin d’aide ? Contactez notre équipe d’assistance à l’adresse support@biorender.com ou démarrez une discussion en direct en cliquant sur la bulle "Chat With Us" située dans le coin inférieur droit.

 

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

Cet article vous a-t-il été utile ?

Utilisateurs qui ont trouvé cela utile : 0 sur 0