Après avoir créé un graphique, vous pouvez l’ajuster sans repartir de zéro. Demandez à l’agent Graphing d’effectuer une modification ou effectuez-la manuellement avec des aperçus en temps réel. Mettez à jour les libellés, les échelles, l’espacement, les regroupements et les couleurs jusqu’à obtenir exactement le résultat souhaité. Vos données sous-jacentes ne changent jamais.

📌 Bêta : l’agent Graphing est en version bêta. 

Avant de commencer : ouvrez votre graphique

Pour commencer à personnaliser votre graphique, sélectionnez-le dans l’onglet Graph en haut de la page Graphing. Vous pouvez également accéder aux graphiques issus du même jeu de données dans cet onglet.

Les graphiques précédents associés à d’autres jeux de données se trouvent dans votre Gallery principale.

Choisissez comment vous souhaitez personnaliser votre graphique

  1. Personnaliser avec l’agent Graphing : décrivez la modification en langage courant.
  2. Personnaliser manuellement : utilisez le panneau « Personnaliser le graphique » et sélectionnez les éléments de votre graphique que vous souhaitez personnaliser.

Vous pouvez passer de l’une à l’autre à tout moment.


Personnaliser avec l’agent Graphing

Comment l’agent personnalise votre graphique

L’agent reste disponible dans les onglets Data, Graph et Analysis, et conserve votre conversation lorsque vous changez d’onglet. Il effectue les modifications avec les mêmes outils Graphing dans BioRender, afin que votre graphique reste modifiable manuellement. Il fonctionne également avec les graphiques et les analyses pris en charge par Graphing (veuillez noter qu’à ce jour, les courbes de survie ne sont pas prises en charge, mais le seront prochainement !).

Vous pouvez demander à l’agent de mettre à jour :

  • Les couleurs
  • Les libellés
  • Les axes
  • Le style des points de données
  • L’apparence de jeux de données ou de traitements spécifiques

Si l’agent ne peut pas répondre à votre demande, il vous le confirmera. Reformulez votre demande ou utilisez le panneau « Personnaliser le graphique ».

Étapes

  1. Cliquez sur « Ask BioRender » en bas au centre de la page, dans l’un des onglets de création de graphiques (Data, Graph, Analysis). Ouvrez la conversation en cliquant sur l’agent ou cliquez sur « Dock to the left » pour afficher la conversation sur le côté de votre onglet.

    Graphing agent chat options

  2. Décrivez les modifications que vous souhaitez effectuer.
  3. Examinez les modifications sur votre graphique. Si le résultat ne vous convient pas, cliquez sur la flèche d’annulation en haut à gauche ou demandez à l’agent d’annuler l’action. 
  4. Continuez. Demandez une autre modification ou effectuez une modification manuelle.
Edit the graph with a simple chat request

Run une analyse et afficher les résultats

Vous pouvez demander à l’agent d’effectuer une analyse ; les résultats apparaissent alors dans l’onglet « Analysis » . 

Exemples de requêtes

  • « Rends les couleurs en niveaux de gris, sauf le composé B, qui doit rester rouge. »
  • « Change tous les points de données en losanges. »
  • « Rends noirs tous les points de données inférieurs à y = 2 ou supérieurs à y = 98. »
  • « Pour tous les points de données dont l’activité est supérieure à 98 % ou inférieure à 2 %, applique un remplissage rouge. »
  • « Remplace la couleur de l’axe X, du noir au bleu. » 

Exemple de requête : 

Avant : « Rends noirs tous les points de données inférieurs à y = 2 ou supérieurs à y = 98 »

Après

Conseils pour formuler vos requêtes à l’agent

  • Pour obtenir les meilleurs résultats : indiquez précisément ce que vous souhaitez modifier et où vous souhaitez appliquer la modification. Par exemple, au lieu de dire « Change les couleurs », essayez « Rends toutes les séries de données grises, sauf le traitement 1, qui doit être rouge ».
  • Si l’agent n’est pas certain, il vous demandera de préciser la variable ou le groupe sur lequel vous souhaitez travailler.

Vos données restent inchangées

Lorsque vous utilisez les fonctionnalités agentiques de Graphing, vos données sont sécurisées avec BioRender. L’agent utilise les outils intégrés d’analyse et de création de graphiques de BioRender, vérifiés par des scientifiques ; il ne lit ni ne modifie vos données et ne les utilise jamais pour entraîner une IA sans votre consentement.

Vos fichiers sont stockés de manière sécurisée dans BioRender et ne peuvent être consultés ou modifiés que par les membres de l’équipe avec lesquels vous choisissez de les partager.

Disponibilité et utilisation

L’agent Graphing est en version bêta. L’utilisation de l’agent Graphing n’entraîne aucun coût supplémentaire. Il est inclus dans notre produit Graphing. 


Personnaliser manuellement

Créer votre graphique

  1. Depuis un jeu de données dans l’onglet Data, cliquez sur le graphique que vous souhaitez créer.
  2. Vous accédez ainsi à la page de modification du Graph.
  3. Attribuez vos variables. L’aperçu du graphique se met à jour en temps réel à mesure que vous remplissez chaque champ.
  4. Une fois que l’aperçu vous convient, cliquez sur "Continue".

Exemple : onglet de personnalisation manuelle du graphique

Options de personnalisation :

  • Apparence des données (couleurs, bordure, espacement)
  • Axe X et axe Y (échelle, libellés, formatage)
  • Réorganiser les groupes le long d’un axe catégoriel
  • Légende (position, texte, espacement)
  • Titre et titres des axes (activation, police, taille, couleur)
  • Affichage des résultats d’analyse (marqueurs de significativité, valeurs p, crochets, espacement)

Ouvrir le panneau de personnalisation du graphique

Cliquez sur "Customize graph" dans l’angle supérieur droit de l’onglet Graph. Le panneau s’ouvre à droite de votre écran et comporte les sections suivantes :

  • Afficher les données : choisissez la manière dont les données sont représentées.
  • Apparence : définissez le thème de couleurs, la police et la couleur.
  • Paramètres supplémentaires : activez ou désactivez le titre du graphique, les titres des axes, les libellés des axes et la légende.

Pour modifier une partie spécifique de votre graphique, cliquez directement dessus. Le panneau se met à jour pour afficher les options de cet élément, comme les données, un axe, la légende ou un titre.

Options d’apparence des données

  1. Cliquez sur « Customize graph » dans l’angle supérieur droit de l’onglet « Graph ».
  2. Cliquez ensuite directement sur la zone de votre graphique que vous souhaitez modifier (par exemple, les données). Le menu « Data Appearance Options » s’ouvre.
  3. Depuis ce menu, vous pouvez :
    • Modifier la palette de couleurs et la couleur de la bordure
    • Ajuster la largeur de la bordure et le rayon des angles
    • Modifier l’espacement entre les groupes, au sein des groupes et la marge du graphique

Pour les graphiques comportant des points de données, comme une courbe dose-réponse, vous pouvez également définir : 

  • Style des groupes : thème de couleurs et couleur de chaque groupe
  • Point de données : forme, taille, remplissage, couleur et largeur de la bordure du point
  • Courbes d’ajustement optimal : couleur de la ligne

Exemple : onglet d’apparence des données lorsque les données sont sélectionnées.

Personnalisation des axes

  1. Cliquez sur l’axe X ou l’axe Y pour ouvrir le menu de personnalisation de l’axe.
  2. Ajustez le formatage de la ligne et des libellés de l’axe.
  3. Pour les axes continus (numériques), vous pouvez modifier l’échelle en :
    • Saisissant manuellement les valeurs minimale et maximale
    • Utilisant les boutons plus/moins pour effectuer des modifications par incréments

Exemple : personnalisation de l’axe X.

Réorganiser les groupes le long d’un axe catégoriel

Vous pouvez réorganiser les groupes le long d’un axe catégoriel sans modifier l’ordre de votre jeu de données sous-jacent.

Pour réorganiser les groupes :

  1. Cliquez sur l’axe catégoriel pour ouvrir le panneau de l’axe.
  2. Utilisez le contrôle "Sort by" pour choisir une méthode de tri :
  • Original : conserve l’ordre par défaut
  • Alphabétique : trie de A à Z ou de Z à A
  • Par valeur (médiane) : trie selon la valeur médiane, par ordre croissant ou décroissant
  • Personnalisé : ouvre une fenêtre de glisser-déposer pour définir votre propre ordre
  1. Chaque option de tri comprend un bouton permettant de choisir l’ordre croissant ou décroissant.

Exemple : panneau "Sort by".

Utiliser un ordre personnalisé

  • Faites glisser les lignes dans la fenêtre pour les réorganiser.
  • Utilisez "Flip order" ou "Reset order" pour effectuer rapidement des ajustements.
  • Chaque ligne comporte également des boutons haut/bas pour la navigation au clavier ou avec un pointeur unique.

Exemple : utilisation d’un ordre personnalisé.

💡 Remarque : la réorganisation par glisser-déposer ne fonctionne qu’à l’intérieur de la fenêtre. Vous ne pouvez pas faire glisser directement les groupes sur le graphique lui-même. L’ajout ou la suppression d’une catégorie au milieu d’un ordre personnalisé peut décaler les autres groupes. Les ajouts en fin de liste et les renommages sont sans risque. Il suffit de faire rapidement glisser à nouveau les éléments dans la fenêtre pour corriger tout décalage.

Personnalisation de la légende

  1. Cliquez sur la légende.
  2. Ouvrez le menu déroulant de personnalisation de la légende, dans lequel vous pouvez :
    • Ajuster la position (gauche, droite, haut, bas)
    • Modifier l’orientation et la taille du texte
    • Modifier l’espacement

Vous pouvez également ajouter une bordure ou un arrière-plan et donner un titre à la légende.

Exemple : options de la légende.

Personnalisation du titre et des titres des axes

  1. Cliquez sur le titre ou sur l’un des titres des axes pour ouvrir le menu de personnalisation.
  2. Vous pouvez :
    • Activer ou désactiver le titre
    • Définir les styles du texte
    • Ajuster la police, la taille, l’espacement et la couleur

Exemple : personnalisation du titre et des titres des axes.

Afficher et mettre en forme les résultats d’analyse

Run votre analyse depuis l’onglet Analysis, puis suivez les étapes ci-dessous pour afficher vos résultats sur le graphique et les mettre en forme.

Comment afficher une analyse

Une fois l’analyse effectuée, vous pouvez l’afficher sur votre graphique. Pour les ANOVAs, cela s’applique uniquement si des comparaisons par paires (par exemple, un test de Tukey) ont été sélectionnées.

  1. Après avoir effectué une analyse, une nouvelle section apparaît dans le panneau du graphique et répertorie toutes les analyses effectuées sur ce graphique.
  2. Développez l’analyse pour afficher tous les contrastes par paires.
  3. Par défaut, les comparaisons significatives sont présélectionnées et affichées automatiquement sur votre graphique.
  4. Cochez ou décochez les comparaisons individuellement pour les afficher ou les masquer, y compris celles qui ne sont pas significatives.

Exemple : affichage d’une analyse. 

Personnaliser l’affichage des analyses

Cliquez sur une ligne ou un crochet de significativité sur votre graphique pour ouvrir le menu d’apparence. Vous pouvez alors :

  • Basculer entre l’affichage sous forme d’astérisques (*) et de valeurs p
  • Modifier le style des crochets, la police et l’épaisseur des lignes
  • Ajuster l’espacement et le positionnement

Exemple : affichage des astérisques. 

💡 Conseil : vous pouvez effectuer plusieurs analyses sur le même graphique et utiliser les cases à cocher pour contrôler les résultats affichés. Cela est utile pour comparer différentes approches de test.

Pour plus d’informations sur la réalisation d’une analyse, consultez Effectuer une analyse statistique.

Besoin d’aide ? Contactez notre équipe d’assistance à l’adresse support@biorender.com ou démarrez une conversation en direct en cliquant sur la bulle "Chat With Us" dans l’angle inférieur droit.

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

Cet article vous a-t-il été utile ?

Utilisateurs qui ont trouvé cela utile : 1 sur 12