Comment ajouter vos données dans BioRender Graphing Comment ajouter vos données dans BioRender Graphing

Comment ajouter vos données dans BioRender Graphing

Il existe deux façons d’importer des données dans un fichier BioRender Graphing :

  1. Smart Data Import : faites glisser-déposer ou importez un fichier pour que vos variables soient détectées automatiquement.
  2. Blank spreadsheet : saisissez ou collez vos données manuellement.

Comment importer vos données

Option 1 : importer un fichier (Smart Data Import)

Smart Data Import nettoie, interprète et prépare automatiquement vos données expérimentales pour la création de graphiques, quelle que soit leur structure ou leur mise en forme. Il n’est pas nécessaire de réorganiser, copier ou coller manuellement vos données. Vous pouvez également générer plusieurs types de graphiques à partir d’un seul jeu de données, ce qui vous permet d’explorer différentes visualisations sans reformater ni dupliquer votre travail.

Comment utiliser Smart Data Import

  1. Créez un nouveau fichier de graphique
    • Depuis votre Gallery, cliquez sur "Create New" > "Graph"  > "Graphing"
    • Vous pouvez également ouvrir un fichier Graph existant si vous poursuivez votre travail sur un jeu de données précédent.
  2. Importez votre jeu de données
    • Dans l’onglet Data, cliquez sur "Upload dataset"
    • Sélectionnez votre fichier (formats pris en charge : .csv, .xls, .xlsx, .prism, .pzfx — jusqu’à 50 Mo)
    • Les fichiers comportant plusieurs feuilles afficheront toutes les feuilles disponibles : sélectionnez-les toutes ou choisissez-en une

  • Pour les fichiers .prism, l’option d’importation des graphiques et des analyses est activée par défaut. Décochez-la si vous souhaitez uniquement importer les données brutes.
  1. Sélectionnez le ou les jeux de données que vous souhaitez importer

  1. Identification automatique des données et des variables
    • Le système :
      • identifie les variables présentes dans votre feuille de calcul 
      • gère les cellules d’en-tête fusionnées
      • ignore les annotations (par exemple, les en-têtes générés par une machine en dehors du jeu de données principal)
      • ignore les lignes ou colonnes vides
  2. Vérifiez les variables
    • Cliquez sur le nom d’une variable pour le modifier
    • Modifiez si nécessaire les cellules mises en évidence pour une variable
    • Vous pouvez également ajouter ou supprimer des variables

💡 Vous importez des données depuis GraphPad Prism ? BioRender prend en charge les fichiers .prism (format le plus récent). Les anciens fichiers .pzfx importeront uniquement les données. Consultez le guide complet : Importation depuis GraphPad Prism

Option 2 : Blank spreadsheet

Commencez avec une feuille de calcul vide et saisissez directement vos données, quelle que soit leur forme ou leur structure. Lorsque vous avez terminé, détectez à nouveau vos variables et BioRender utilisera le même processus Smart Data Import pour détecter automatiquement vos variables et vous permettre de créer des graphiques.

  1. Créez un nouveau fichier de graphique
    1. Depuis votre Gallery, cliquez sur "Create New" > "Graph" > "Graphing"
    2. Vous pouvez également ouvrir un fichier Graph existant si vous poursuivez votre travail sur un jeu de données précédent.
  2. Cliquez sur "Blank spreadsheet" dans l’onglet Data.
  3. Copiez-collez vos données.
  4. Ajoutez ou supprimez des lignes et des colonnes selon vos besoins en cliquant avec le bouton droit sur une cellule.
  5. Cliquez sur "Re-detect variables" lorsque vous avez terminé afin d’analyser votre jeu de données.
    • BioRender Graphing appliquera les étapes de Smart Data Import pour détecter automatiquement vos variables et vous permettre de créer des graphiques.
  6. Une invite en bas de l’écran vous indiquera également si de nouvelles données sont saisies : "We noticed you added new data. Re-run Smart Data Import?"

Recommandations pour tous les jeux de données

  • Pour l’importation : taille maximale du File (tous les types de fichiers) : 50 Mo
  • Pour l’importation ou la saisie manuelle dans une feuille de calcul vide : nombre maximal Recommended de 5 000 points de données pour créer des graphiques et exécuter des analyses. Les fichiers plus volumineux peuvent entraîner des performances très lentes.

Limites de données Recommended pour les fichiers CSV ou Excel

Pour des performances optimales, veillez à respecter les limites suivantes :

Limite Valeur Recommended
Nombre maximal de colonnes 50
Nombre maximal de lignes 10 000

Ces limites garantissent :

  • Des temps de traitement rapides (moins de 10 secondes)
  • La compatibilité avec les fonctionnalités d’analyse statistique
  • Des importations fiables pour tous les types de données

Limites des fichiers Prism File

  • 50 tableaux de données maximum dans un fichier Prism

Limites de données Recommended pour les fichiers Prism

Limite  Valeur
Lignes par tableau 10 000
Colonnes par tableau 100
Nombre total de points de données (tous les tableaux) 100 000

Remarque : si votre fichier Prism comporte de nombreux tableaux, veillez à maintenir le nombre total de points de données sous 100 000 (par exemple, 10 tableaux × 10 000 points).

Organisation des jeux de données

Une fois importé, chaque jeu de données apparaît sous forme d’onglet en bas de l’onglet Data.  Vous pouvez cliquer sur les différents onglets pour afficher les jeux de données. Les variables du jeu de données actif sont répertoriées dans le panneau de gauche.

Depuis la vue des données, vous pouvez :

  • Ajouter ou supprimer manuellement des variables, des lignes ou des colonnes
  • Renommer les variables
  • Voir quels graphiques sont liés à chaque jeu de données.

Et ensuite ?

Une fois vos données importées, vous pouvez commencer à créer des graphiques. Pour créer votre premier graphique, cliquez sur « Create New Graph » dans l’onglet des données du panneau de droite, ou rendez-vous dans l’onglet Graph , appliquez les recommandations d’analyse pour choisir le test statistique approprié et personnalisez vos visuels, le tout sans quitter BioRender.

Découvrez comment Run une analyse statistique dans BioRender Graphing →

Besoin d’aide ? Contactez notre équipe d’assistance à l’adresse support@biorender.com ou démarrez une conversation en direct en cliquant sur la bulle "Chat With Us" située dans le coin inférieur droit.

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

Cet article vous a-t-il été utile ?

Utilisateurs qui ont trouvé cela utile : 3 sur 6