Comment ajouter vos données dans BioRender Graphing Comment ajouter vos données dans BioRender Graphing

Comment ajouter vos données dans BioRender Graphing

Il existe deux façons d’importer des données dans un fichier BioRender Graphing :

  1. Smart Data Import - téléchargez un fichier et vos variables seront détectées automatiquement.
  2. Blank Spreadsheet - saisissez ou collez vos données manuellement.

Comment importer vos données

Option 1 : Télécharger un fichier (Smart Data Import)

L’importation intelligente des données nettoie, interprète et prépare automatiquement vos données expérimentales pour la création de graphiques, quelle que soit leur structure ou leur format. Il n’est pas nécessaire de réorganiser, copier ou coller manuellement vos données. Vous pouvez également générer plusieurs types de graphiques à partir d’un seul ensemble de données, ce qui vous offre la flexibilité d’explorer différentes visualisations sans reformater ni dupliquer votre travail.

Comment utiliser l’importation intelligente des données

  1. Créez un nouveau fichier de graphique

    • Depuis votre Galerie, cliquez sur « Create New » > « Graph » > « Graphing »
    • Ouvert alternativement un fichier Graph existant si vous poursuivez un travail sur un jeu de données précédent.
  2. Téléchargez votre jeu de données
    • Dans l’onglet Data, cliquez sur « Upload Dataset »
    • Sélectionnez votre fichier (formats supportés : .csv, .xls, .xlsx, .prism, .pzfx — jusqu’à 50 Mo)
    • Les fichiers comportant plusieurs feuilles afficheront toutes les feuilles disponibles — sélectionnez-les toutes ou choisissez-en une seule

  • Pour les fichiers .prism, l’option d’importer les graphiques et analyses est activée par défaut. Décochez cette option si vous souhaitez uniquement les données brutes.
  1. Sélectionnez le(s) jeu(x) de données que vous souhaitez importer

  1. Identification automatique des données et variables
    • Le système :
      • identifie automatiquement les variables présentes dans votre feuille de calcul
      • gère les cellules d’en-tête fusionnées
      • ignore les annotations (par exemple les en-têtes de sortie machine en dehors du jeu de données principal)
      • ignore les lignes ou colonnes vides
  2. Vérifiez les variables
    • Cliquez sur un nom de variable pour le modifier
    • Modifiez les cellules surlignées pour une variable si nécessaire
    • Vous pouvez également ajouter ou supprimer des variables

💡 Vous importez depuis GraphPad Prism ? BioRender prend en charge les fichiers .prism (format le plus récent). Les anciens fichiers .pzfx importeront uniquement les données. Consultez le guide complet : Importer depuis GraphPad Prism

Option 2 : Blank Spreadsheet

Commencez avec une feuille de calcul vide et saisissez vos données directement dans n’importe quel format ou structure. Une fois terminé, redétectez vos variables et BioRender utilisera le même processus d’importation intelligente des données pour détecter automatiquement vos variables et vous préparer à créer des graphiques.

  1. Créez un nouveau fichier de graphique
    1. Depuis votre Galerie, cliquez sur « Create New » > « Graph » > « Graphing »
    2. Ouvert alternativement un fichier Graph existant si vous poursuivez un travail sur un jeu de données précédent.
  2. Cliquez sur « Blank Spreadsheet » dans l’onglet Données.
  3. Copiez et collez vos données.
  4. Ajoutez ou supprimez des lignes et des colonnes selon vos besoins en cliquant avec le bouton droit sur n’importe quelle cellule.
  5. Cliquez sur « Re-detect variables » une fois terminé pour analyser votre jeu de données.
    • BioRender Graphing utilisera les étapes de l’importation intelligente des données pour détecter automatiquement vos variables et vous préparer à créer des graphiques.
  6. Une invite en bas de l’écran vous avertira également si de nouvelles données sont saisies : « We noticed you added new data. Re-run Smart Data Import ? »

Recommandations pour tous les jeux de données

  • Pour le téléchargement : taille maximale du fichier (tous types de fichiers) : 50 Mo
  • Pour le téléchargement ou la saisie manuelle dans une feuille de calcul vierge : maximum recommandé de 5 000 points de données pour créer des graphiques et effectuer des analyses. Les fichiers plus volumineux peuvent entraîner des performances très lentes.

Limites recommandées pour les fichiers CSV ou Excel

Pour de meilleures performances, maintenez vos données dans ces limites :

Limite Valeur recommandée
Colonnes maximum 50
Lignes maximum 10 000

Ces limites garantissent :

  • Des temps de traitement rapides (moins de 10 secondes)
  • La compatibilité avec les fonctionnalités d’analyse statistique
  • Des imports fiables pour tous les types de données

Limites des fichiers Prism

  • Maximum 50 tableaux de données dans un fichier Prism

Limites recommandées pour les fichiers Prism

Limite  Valeur
Lignes par tableau 10 000
Colonnes par tableau 100
Nombre total de points de données (tous tableaux) 100 000

Note : Si votre fichier Prism contient de nombreux tableaux, maintenez le nombre total de points de données en dessous de 100 000 (par exemple, 10 tableaux × 10 000 points).

Organisation des jeux de données

Une fois importé, chaque jeu de données apparaît sous forme d’onglet en bas de l’onglet Données. Vous pouvez cliquer entre les jeux de données pour les consulter. Les variables du jeu de données actif sont listées dans le panneau de gauche.

Depuis la vue des données, vous pouvez :

  • Ajouter ou supprimer manuellement des variables, des lignes ou des colonnes
  • Renommer des variables
  • Voir quels graphiques sont liés à chaque jeu de données

Et ensuite ?

Une fois vos données importées, vous êtes prêt à commencer à créer des graphiques. Pour créer votre premier graphique, cliquez sur « Créer un nouveau graphique » depuis l’onglet données dans le panneau de droite ou rendez-vous dans l’onglet Graph, appliquez les conseils d’analyse pour choisir le bon test statistique, et personnalisez vos visuels — le tout sans quitter BioRender.

Apprenez comment réaliser une analyse statistique dans BioRender Graphing →

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

Cet article vous a-t-il été utile ?

Utilisateurs qui ont trouvé cela utile : 3 sur 6