Wenn Sie mit Daten arbeiten, die Muster, Intensitäten oder Variationen in einer rasterähnlichen Struktur erfassen, beispielsweise Temperaturmesswerte, Genexpressionswerte oder Assays auf Mikrotiterplatten, kann eine Heatmap eine hervorragende Möglichkeit sein, Ihre Daten zu visualisieren. Mit Well-Plate-Heatmaps und Heatmaps können Sie Trends und Ausreißer schnell erkennen, indem Farben Werte darstellen. Dadurch lassen sich Ihre Ergebnisse leichter interpretieren und vermitteln. So erstellen Sie sie in BioRender Graphing.
📌 Beta: Der Graphing-Agent befindet sich in der Betaphase.
Bevor Sie beginnen
BioRender Graphing bietet zwei Heatmap-Optionen:
- Reguläre Heatmaps: Vielseitig einsetzbar und für eine Vielzahl von Datensätzen geeignet.
- Well-Plate-Heatmaps: Speziell für Daten aus Mikrotiterplatten entwickelt, wobei jede Zelle eine Zeile und Spalte der Platte darstellt.
Unabhängig davon, wie Sie Ihre Heatmap erstellen:
- Jeder Wert im Datensatz entspricht derselben Position auf der Heatmap (z. B. befindet sich Zeile 1, Spalte 1 in der oberen linken Ecke).
- Sie können Ihre eigenen Daten direkt in den Datensatz einfügen.
- Smart Data Import organisiert Ihre Daten für Sie.
Wählen Sie aus, wie Sie Ihre Heatmap erstellen möchten
- Mit dem Graphing-Agenten: Laden Sie Ihre Daten hoch und beschreiben Sie die gewünschte Heatmap.
- Manuell: Wählen Sie im Bereich „Graphs“ eine Heatmap aus und weisen Sie Ihre Variablen selbst zu.
Sie können jederzeit zwischen den beiden Optionen wechseln.
Mit dem Graphing-Agenten
Schritt 1: Daten hinzufügen
- Öffnen Sie eine neue Graphing-Datei.
- Klicken Sie in der Nachricht des Agenten auf „Upload data“ oder auf die Schaltfläche „+“ im Chatfeld.
- Wählen Sie Ihre Datei aus, wählen Sie die gewünschten Datensätze aus und klicken Sie auf „Import data“.
- Der Agent beschreibt Ihre Daten und hebt die erkannten Variablen hervor.
Weitere Informationen finden Sie unter So fügen Sie Ihre Daten in BioRender Graphing hinzu.
Schritt 2: Bitten Sie um eine Heatmap
Bitten Sie den Agenten im Chat um die gewünschte Heatmap. Beispiel: „Create a well plate heatmap from [dataset name].“ Der Agent schlägt einen Diagrammtyp vor, der zu Ihren Daten passt. Sagen Sie ja oder bestätigen Sie, dass Sie einen anderen Diagrammtyp wünschen.
Schritt 3: Überprüfen Sie Ihre Variablen und erstellen Sie das Diagramm
Der Agent teilt Ihnen mit, welche Angaben das Diagramm benötigt, und weist Ihre Variablen zu. Überprüfen Sie, ob „Row factor“ und „Column factor“ mit Ihren Zeilen- und Spaltenbezeichnungen übereinstimmen. Wenn nicht eindeutig ist, welche Variable Sie meinen, fragt der Agent nach. Klicken Sie auf „Create the graph“, wenn der Plan korrekt aussieht.
Schritt 4: Passen Sie Ihre Heatmap an
Klicken Sie auf „Ask BioRender“ und beschreiben Sie die gewünschte Änderung. Beispiel: „Change the color of the heatmap from blue to red.“
- Nennen Sie den Teil, den Sie anpassen möchten, z. B. „the color bar“ oder „the row labels“. Beachten Sie, dass Sie kein Diagrammelement anklicken und an den Chat senden können.
- Wenn Ihnen eine Änderung nicht gefällt, klicken Sie oben links auf den Rückgängig-Pfeil oder bitten Sie den Agenten, die Aktion rückgängig zu machen.
- Wenn der Agent etwas nicht ausführen kann, teilt er Ihnen mit, was nicht abgeschlossen werden konnte. Formulieren Sie Ihre Anfrage um oder bearbeiten Sie sie manuell im Bereich „Customize Graph“.
Weitere Informationen zum Agenten finden Sie unter So verwenden Sie den Graphing-Agenten in BioRender Graphing (Beta).
Manuell
Schritt 1: Daten hinzufügen
Klicken Sie im Tab „Data“ auf „Blank spreadsheet“ und fügen Sie Ihre Daten ein oder geben Sie sie ein.
Schritt 2: Heatmap oder Well-Plate-Heatmap auswählen
Klicken Sie auf „Create New“ und öffnen Sie das Menü Graph. Wählen Sie „Heatmap“ oder „Well plate heatmap“ aus.
Schritt 3: Variablen hinzufügen
Geben Sie die Variablen für „Row factor“, „Column factor“ und „Values“ an. Die Zeilen- und Spaltenfaktoren sollten auf die Variablen festgelegt werden, die Ihre Zeilen- und Spaltenbezeichnungen enthalten. Weisen Sie jede Variable im Detailbereich Graph zu. Klicken Sie auf „Continue“, wenn die Vorschau korrekt aussieht.
Schritt 4: Passen Sie Ihre Well-Plate-Heatmap oder Heatmap an
Sie können viele Elemente der Heatmap anpassen, ähnlich wie bei anderen BioRender-Graphing-Visualisierungen, einschließlich Schriftart, Diagrammtitel und Achsenbeschriftungen.
Klicken Sie oben rechts im Tab Graph auf „Customize graph“ oder klicken Sie auf den Teil des Diagramms, den Sie ändern möchten. Sie können Folgendes anpassen:
- Unabhängige Achse
- Abhängige Achse
- Legende
- Graph-Titel
- Beispieldaten
Für Heatmaps und Well-Plate-Heatmaps:
- Datennormalisierung: Wenden Sie die Skalierung nach Zeile oder Spalte an. Dadurch wird eine Z-Score-Standardisierung pro Zeile oder Spalte durchgeführt. Die Wertbeschriftungen, Elementfarben und der Farbbalken werden automatisch angepasst, um die Änderungen widerzuspiegeln.
- Anpassung des Farbbalkens: Klicken Sie auf den Farbbalken, um das Anpassungsmenü zu öffnen. Dort können Sie seine Position im Diagramm ändern sowie Rahmen und Hintergrund anpassen.
Nur für Heatmaps:
- Form der Heatmap: Die Standardform ist quadratisch. Erhöhen Sie den Eckenradius, um die Ecken abzurunden.
- Abstände und Rand: Passen Sie den Abstand zwischen den Zellen sowie den Rand zwischen den Zeilen- und Spaltenbeschriftungen und den Zellen an. Wenn Sie den Abstand auf 0 setzen, werden die Lücken zwischen den Datenpunkten entfernt. Der Rand fügt zusätzlichen Platz hinzu.
Nur für Well-Plate-Heatmaps:
- Rand der Mikrotiterplatte: Abgerundete Ecken sind die Standardeinstellung. Klicken Sie auf eine beliebige Stelle der Heatmap, um die Randeinstellungen anzupassen.
- Anpassung der Well-Darstellung: Passen Sie den Abstand zwischen den Wells, die Rahmenbreite und die Rahmenfarbe an Ihre Visualisierung an.
- Rand und Innenabstand: Der Rand passt den Abstand zwischen den Zeilen- und Spaltenbeschriftungen und der Platte an. Der Innenabstand beeinflusst den Abstand zwischen den Wells und dem Rand der Platte.
Alle Anpassungsoptionen finden Sie unter So passen Sie Ihr Diagramm an.
Tipps zur Fehlerbehebung
Leere Wells in Ihrer Well-Plate-Heatmap?
Wenn Sie neben Ihren Daten leere Wells anzeigen möchten, geben Sie für diese Wells Zeilen- und Spaltennamen ein. Wenn die Bezeichnungen leer bleiben, wird die Heatmap möglicherweise unvollständig angezeigt.
Benötigen Sie Clustering- oder Analyseoptionen?
Wir arbeiten aktiv an diesen Funktionen. Bleiben Sie auf dem Laufenden! Der Agent führt nur Analysen aus, die Graphing unterstützt, daher kann er derzeit noch kein Clustering durchführen.
Zwischen Heatmap-Typen wechseln?
Sie können über das Dropdown-Menü zwischen regulären Heatmaps und Well-Plate-Heatmaps wechseln. Beachten Sie, dass nicht alle Anpassungen übernommen werden. Möglicherweise müssen Sie daher nach dem Wechsel einige Einstellungen anpassen. Wir empfehlen, Ihr Diagramm zu duplizieren, bevor Sie einen anderen Visualisierungstyp ausprobieren.
Der Agent hat die von mir angeforderte Heatmap nicht erstellt.
Teilen Sie ihm mit, welchen Heatmap-Typ Sie wünschen, oder wählen Sie selbst einen im Bereich „Graphs“ auf dem Tab „Data“ aus.
Benötigen Sie Hilfe? Wenden Sie sich unter support@biorender.com an unser Supportteam oder starten Sie einen Live-Chat, indem Sie unten rechts auf die Sprechblase "Chat With Us" klicken.
War dieser Beitrag hilfreich?
Beiträge in diesem Abschnitt
- BioRender Graphing: Verfügbare Diagrammtypen und Analysen
- Statistische Tests in BioRender Graphing: Methoden, Annahmeprüfungen und R-Pakete
- Statistische Analyse: Verfügbare Tests und deren Durchführung
- Statistische Analysen in BioRender Graphing durchführen
- Wie BioRender den richtigen statistischen Test für Ihre Daten empfiehlt
- Ausreißererkennung verstehen (ROUT-Methode)
- So stellen Sie kontinuierliche (XY-)Daten in BioRender Graphing grafisch dar und analysieren sie
- So passen Sie eine Standardkurve an und interpolieren unbekannte Werte aus Plattendaten
- Erstellen von Heatmaps und Well Plate Heatmaps in BioRender Graphing