如何在 BioRender Graphing 中添加数据 如何在 BioRender Graphing 中添加数据

如何在 BioRender Graphing 中添加数据

📌 Beta:Graphing 智能代理目前处于测试阶段。 

有两种方式可以将数据添加到 BioRender Graphing 文件中:

  1. 使用 Graphing 智能代理:在聊天中上传文件。
  2. 手动添加:从“数据”选项卡上传文件,或将数据输入或粘贴到空白电子表格中。

无论采用哪种方式,Smart Data Import 都会自动检测变量,因此无需重新设置格式。你可以随时在两种方式之间切换。

使用 Graphing 智能代理

BioRender AI 智能代理使用 Smart Data Import 自动解读并准备实验数据,以便进行绘图,无论数据的结构或格式如何。对于大多数格式,无需手动重新排列、复制或粘贴数据。你还可以根据单个数据集生成多种图表类型,从而灵活探索不同的可视化方式,而无需重新设置格式或重复工作。你的底层数据不会被更改。

创建新的图表文件

  1. 在你的 Gallery 中,点击“创建新文件” > “Graph” > “Graphing”。
  2. 如果要继续处理之前的数据集,也可以打开现有的 Graph 文件。

上传数据集

  1. 在智能代理消息中点击“上传数据”,或点击聊天框中的“+”按钮。
  2. 选择文件。支持的格式:.csv、.xls、.xlsx、.prism 和 .pzfx(最大 50 MB)。 
  3. 在“从文件中选择数据集”窗口中,选择所需的数据集,或选择“全选”,然后点击“导入数据”。包含多个工作表的文件会显示所有可用的工作表。
  4. 对于 .prism 文件,默认开启导入图表和分析功能。如果只需要原始数据,请取消选中该选项。 
  5. 智能代理会确认添加的内容、描述你的数据,并突出显示检测到的变量。

示例:在 Graphing 智能代理聊天中上传数据(中央聊天视图)

Upload your data with the Graphing agent

示例:选择数据集(中央聊天视图)

Choose the data you want to import

💡 你无法将文件作为聊天消息发送。请使用“上传数据”或“+”按钮。两者都会打开相同的导入窗口。

检查变量

这些编辑需要手动完成。智能代理不会更改你的数据。

  • 点击变量名称进行编辑。
  • 如有需要,编辑变量对应的突出显示单元格。
  • 你还可以添加或删除变量。

Review the variables

创建第一个图表

智能代理会根据你的数据建议图表类型。按照它的提示操作,或直接请求所需的图表。完整操作流程请参阅如何在 BioRender Graphing 中使用 Graphing 智能代理。

稍后添加更多数据

点击聊天框中的“+”按钮上传其他文件。


手动添加

选项 1:上传文件(Smart Data Import)

Smart Data Import 会解读并准备数据,以便进行绘图,无论数据采用何种结构。无需重新排列、复制或粘贴任何内容。你还可以根据一个数据集创建多种图表类型。

选项 2:Blank spreadsheet

以任意格式输入或粘贴数据。完成后,重新检测变量,BioRender 就会为绘图做好准备。

如何使用 Smart Data Import

  1. 创建新的图表文件
    • 在你的 Gallery 中,点击 "Create New" > "Graph"  > "Graphing"
    • 如果要继续处理之前的数据集,也可以打开现有的 Graph 文件。
  2. 上传数据集
    • 在“数据”选项卡中,点击 "Upload dataset"
    • 选择文件(支持的格式:.csv、.xls、.xlsx、.prism、.pzfx — 最大 50MB)
    • 包含多个工作表的文件会显示所有可用的工作表 — 选择全部或其中一个

Drag and drop your data in or start from a blank spreadsheet or sample dataset

  • 对于 .prism 文件,默认开启导入图表和分析功能。如果只需要原始数据,请取消选中该选项。
  1. 选择要导入的数据集。

Choose the data you want to import

  1. 自动识别数据和变量。系统会自动:
    • 识别电子表格中存在的变量 
    • 处理合并的标题单元格
    • 忽略注释(例如,主数据集之外的设备输出标题)
    • 忽略空行或空列
  2. 检查变量
    • 点击变量名称进行编辑
    • 如有需要,编辑变量对应的突出显示单元格
    • 你还可以添加或删除变量

💡 从 GraphPad Prism 导入?BioRender 支持 .prism 文件(最新格式)。较旧的 .pzfx 文件只能导入数据。请参阅完整指南:从 GraphPad Prism 导入


所有数据集的建议

  • 上传:File 大小上限(所有文件类型):50 MB
  • 上传文件或手动将数据输入空白电子表格:创建图表和运行分析时,Recommended 最大数据点数为 5,000。超过此数量的文件可能会导致性能非常缓慢。

CSV 或 Excel 文件的Recommended数据限制

为获得最佳性能,请将数据控制在以下限制范围内:

限制 Recommended 值
最大列数 50
最大行数 10,000

这些限制可确保:

  • 处理速度快(少于 10 秒)
  • 与统计分析功能兼容
  • 所有数据类型均可可靠导入

Prism File 限制

  • 一个 Prism 文件中最多包含 50 个数据表

prism 文件的Recommended数据限制

限制  值
每个表的行数 10,000
每个表的列数 100
数据点总数(所有表) 100,000

注意:如果你的 Prism 文件包含多个表,请将数据点总数控制在 100,000 以下(例如,10 个表 × 10,000 个数据点)。

数据集的组织方式

导入后,每个数据集都会作为一个选项卡显示在“数据”选项卡底部。 你可以点击不同的数据集进行查看。当前数据集的变量会列在左侧面板中。

示例:带有侧面板智能代理聊天视图的数据选项卡。

Alternate between datasets in the tabs below

在数据视图中,你可以:

  • 手动添加或删除变量、行或列
  • 重命名变量
  • 查看哪些图表与每个数据集相关联。

Add, delete or rename your variables

接下来做什么?

数据准备就绪后,你可以开始创建图表。要创建第一个图表,请在右侧面板的数据选项卡中点击“Create New Graph”,或前往 Graph 选项卡,应用分析指导来选择合适的统计检验,并自定义视觉效果——无需离开 BioRender。

了解如何在 BioRender Graphing 中Run统计分析 →

需要帮助? 请通过 support@biorender.com 联系我们的支持团队,或点击右下角的 "Chat With Us" 气泡开始实时聊天。

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

这篇文章有帮助吗?

6 人中有 3 人觉得有帮助