如何将您的 Prism 文件导入 BioRender Graphing 如何将您的 Prism 文件导入 BioRender Graphing

如何将您的 Prism 文件导入 BioRender Graphing

如果您已有 Prism 文件,可以将其直接导入 BioRender Graphing,包括数据、图表和分析结果。 

📌 Beta 版:Graphing 代理目前处于 Beta 阶段。 

支持的文件格式

  • BioRender 支持 .prism 文件格式(最新的 Prism 格式)。
  • 较旧的 .pzfx 文件仅部分支持。数据可以导入,但图表和分析结果无法导入。
  • 如需完整保留图表和分析结果并导入 .pzfx 文件,请先在 GraphPad Prism 中将其重新保存为 .prism 文件,然后再进行导入。
  • 可以导入最大 50 MB 的文件。

Prism 文件限制

一个 Prism 文件中最多包含 50 个数据表。

Prism 文件的建议数据限制

限制 值
每个表的行数 10,000
每个表的列数 100
数据点总数(所有表) 100,000

如果您的 Prism 文件包含许多表,请将数据点总数控制在 100,000 以下(例如,10 个表 × 10,000 个数据点)。

如何导入您的 Prism 文件

选择您想要的导入方式:

  1. 使用 Graphing 代理:在聊天中上传。
  2. 手动导入:拖放文件,或在“数据”选项卡中使用“添加数据集”。

您可以随时在两种方式之间切换。

使用 Graphing 代理

  1. 创建新的图表文件。在您的 Gallery 中,点击“创建新内容” > “Graph” > “Graphing”。或者打开现有的 Graphing 文件。
  2. 在代理的消息中点击“上传数据”,或点击聊天框中的“+”按钮。
  3. 选择您的 .prism 文件。
  4. 在“从您的文件中选择数据集”窗口中,文件中的所有数据集都会显示出来。选择全部数据集,或选择特定数据集。
  5. 默认情况下,导入图表和分析结果的选项处于启用状态。如果您只想导入原始数据,请取消选中此选项。 
  6. 点击“导入数据”。
  7. 代理会确认已添加的内容,并描述您的数据。

示例:图表代理聊天框。

The graphing agent chat box

示例:聊天时在左侧面板中打开代理,以使用另一种视图。

The Graphing agent chat box opened on side panel

💡 您无法将文件作为聊天消息发送。请使用“上传数据”或“+”按钮。两者都会打开同一个导入窗口。

视频教程

如需详细了解代理,请参阅如何在 BioRender Graphing 中使用 Graphing 代理。


手动导入

选项 1:拖放

将您的 Prism 文件拖放到 BioRender Graphing 中。您的 Prism 图表会自动转换为 BioRender 样式,同时保留所有分析结果。 

Drag and drop your files straight into BioRender

选项 2:点击 Upload dataset

  1. 在“数据”选项卡中,点击“添加数据集”,然后选择您的 .prism 文件。 
  2. 文件中的所有数据集都会显示出来。选择全部数据集,或选择特定数据集。
  3. 默认情况下,导入图表和分析结果的选项处于启用状态。如果您只想导入原始数据,请取消选中此选项。
  4. 点击“导入数据”。

Prism file dataset

导入的内容

这适用于通过代理导入和手动导入。

  • 所有选定的数据集都会以选项卡的形式显示在“数据”选项卡中,并显示相关图表。
  • 在 Graph Grid 视图中,导入的图表会清楚地标有 Prism 导入徽章。
  • 在“分析”选项卡中,导入的分析结果会显示,并附带其结果;任何显著性标记都会自动应用到相应的图表。
  • 您可以像操作自己运行的分析一样操作导入的分析:打开或关闭结果、调整设置,或在其基础上运行新的分析。

注意事项

  • 不会保留样式。Prism 图表自定义设置(颜色、字体、格式)无法从 Prism 文件中提取。BioRender 会根据数据尽可能以 BioRender 样式重新创建图表,之后您可以重新设置样式。您可以手动完成,也可以要求 Graphing 代理更改颜色和样式。 
  • 某些分析输出可能无法使用。例如,dose-response 曲线的 95% 置信区间可能无法仅从 Prism 文件中重新创建。在这种情况下,该选项会显示为灰色,并通过工具提示指导您在 BioRender 中运行新的分析以生成结果。
  • Prism 导入功能适用于常见的图表类型,例如柱状图和 ANOVAs。更复杂的曲线拟合可能需要在 BioRender 中重新运行分析。

BioRender Graphing 与 GraphPad Prism 有何不同?

BioRender Graphing 是 GraphPad Prism 的替代方案,提供科学家依赖的核心分析功能,无需手动操作,也没有陡峭的学习曲线。无需重新格式化即可导入原始数据,获取引导式统计分析,并使用 Graphing 代理(Beta 版)通过自然语言提示自定义适用于出版物的高质量图表,无需学习新的工具。 

所有操作都在一个安全的工作区中完成,无需安装,并内置协作功能,因此您可以随时随地访问您的工作,并与团队实时协作。比较 BioRender Graphing 与 GraphPad Prism。

需要帮助?请通过 support@biorender.com 联系我们的支持团队,或点击右下角的 "Chat With Us" 气泡,开始在线聊天。

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

这篇文章有帮助吗?

2 人中有 2 人觉得有帮助