Come aggiungere i tuoi dati in BioRender Graphing Come aggiungere i tuoi dati in BioRender Graphing

Come aggiungere i tuoi dati in BioRender Graphing

Ci sono due modi per importare i dati in un file BioRender Graphing:

  1. Smart Data Import - carica un file e lascia che le tue variabili vengano rilevate automaticamente.
  2. Blank Spreadsheet - inserisci o incolla i tuoi dati manualmente.

Come importare i tuoi dati

Opzione 1: Carica un file (Smart Data Import)

L'Importazione dati intelligente pulisce, interpreta e prepara automaticamente i tuoi dati sperimentali per la creazione di grafici, indipendentemente da come sono strutturati o formattati. Non è necessario riorganizzare, copiare o incollare manualmente i dati. Puoi inoltre generare diversi tipi di grafici da un unico set di dati, offrendoti la flessibilità di esplorare diverse visualizzazioni senza dover riformattare o duplicare il lavoro.

Come utilizzare l'Importazione dati intelligente

  1. Crea un nuovo file grafico
    • Dalla tua Galleria, clicca su "Create New" > "Graph" > "Graphing"
    • In alternativa, apri un file Graph esistente se vuoi continuare a lavorare su un set di dati precedente.
  2. Carica il tuo set di dati
    • Nella scheda Data, clicca su "Upload Dataset"
    • Seleziona il tuo file (formati supportati: .csv, .xls, .xlsx, .prism, .pzfx — fino a 50MB)
    • I file con più fogli mostreranno tutti i fogli disponibili — seleziona tutti o scegli uno

  • Per i file .prism, l'opzione per importare grafici e analisi è attivata di default. Deseleziona questa opzione se desideri importare solo i dati grezzi.
  1. Seleziona il/i set di dati che vuoi importare

  1. Identificazione automatica dei dati e delle variabili
    • Il sistema automaticamente:
      • identifica le variabili presenti nel tuo foglio di calcolo
      • Gestisce le celle di intestazione unite
      • Ignora annotazioni (ad es. intestazioni di output macchina fuori dal dataset principale)
      • Ignora righe o colonne vuote
  2. Revisiona le variabili
    • Clicca sul nome di una variabile per modificarla
    • Modifica le celle evidenziate per una variabile se necessario
    • Puoi anche aggiungere o eliminare variabili

💡 Importi da GraphPad Prism? BioRender supporta i file .prism (formato più recente). I file .pzfx più vecchi importeranno solo i dati. Consulta la guida completa: Importare da GraphPad Prism

Opzione 2: Blank Spreadsheet

Inizia con un foglio di calcolo vuoto e inserisci i tuoi dati direttamente in qualsiasi formato o struttura. Quando hai finito, rileva nuovamente le tue variabili e BioRender utilizzerà lo stesso processo di Importazione dati intelligente per rilevare automaticamente le variabili e prepararti alla creazione del grafico.

  1. Crea un nuovo file grafico

    1. Dalla tua Galleria, clicca su "Create New" > "Graph" > "Graphing"
    2. In alternativa, apri un file Graph esistente se vuoi continuare a lavorare su un set di dati precedente.
  2. Clicca su "Blank Spreadsheet" nella scheda Dati.
  3. Copia e incolla i tuoi dati.
  4. Aggiungi o elimina righe e colonne secondo necessità cliccando con il tasto destro su una qualsiasi cella.
  5. Clicca su "Re-detect Variables" quando hai finito per analizzare il tuo set di dati.
    • BioRender Graphing utilizzerà i passaggi dell'Importazione dati intelligente per rilevare automaticamente le tue variabili e prepararti alla creazione del grafico.
  6. Un messaggio in basso allo schermo ti notificherà anche se vengono inseriti nuovi dati: "Abbiamo notato che hai aggiunto nuovi dati. Rilanciare l'Importazione dati intelligente?"

Raccomandazioni per tutti i set di dati

  • Per il caricamento: Dimensione massima file (tutti i tipi): 50 MB
  • Per il caricamento o l'inserimento manuale in foglio di calcolo vuoto: massimo consigliato di 5.000 punti dati per creare grafici ed eseguire analisi. File più grandi potrebbero avere prestazioni molto lente.

Limiti consigliati per dati CSV o Excel

Per le migliori prestazioni, mantieni i tuoi dati entro questi limiti:

Limite Valore consigliato
Colonne massime 50
Righe massime 10.000

Questi limiti garantiscono:

  • Tempi di elaborazione rapidi (meno di 10 secondi)
  • Compatibilità con le funzionalità di analisi statistica
  • Importazioni affidabili per tutti i tipi di dati

Limiti dei file Prism

  • Massimo 50 tabelle dati all'interno di un file Prism

Limiti consigliati per i file prism

Limite  Valore
Righe per tabella 10.000
Colonne per tabella 100
Punti dati totali (tutte le tabelle) 100.000

Nota: Se il tuo file Prism ha molte tabelle, mantieni il totale dei punti dati sotto 100.000 (ad es., 10 tabelle × 10.000 punti).

Come sono organizzati i set di dati

Una volta importati, ogni set di dati appare come una scheda lungo il fondo della scheda Dati. Puoi cliccare tra i set di dati per visualizzarli. Le variabili del set di dati attivo sono elencate nel pannello a sinistra.

Dalla vista dati, puoi:

  • Aggiungere o eliminare manualmente variabili, righe o colonne
  • Rinominare variabili
  • Vedere quali grafici sono collegati a ciascun set di dati

Cosa fare dopo?

Una volta inseriti i dati, sei pronto per iniziare a creare grafici. Per creare il tuo primo grafico, clicca su ‘Crea nuovo grafico’ dalla scheda dati nel pannello a destra oppure vai alla scheda Graph, applica la guida all’analisi per scegliere il test statistico corretto e personalizza i tuoi visual - tutto senza uscire da BioRender.

Scopri come eseguire un'analisi statistica in BioRender Graphing →

What's new →
Discover more in BioRender
 
 BioRender AI

Draft custom figures in seconds from a text prompt.

Learn more → Browse help articles →
 
 Graphing

Turn raw data into journal-quality graphs in minutes.

Learn more → Browse help articles →

Questo articolo ti è stato utile?

Utenti che ritengono sia utile: 3 su 6