现在您已输入数据,可以创建您的 Graph,并进行精确的图表编辑,包括标签、刻度、间距、分组和颜色,同时实时预览,以便获得您想要的最终效果。
本文将分步介绍如何修改各种元素,而无需重新创建图表。
从新图表开始
- 在 Data 选项卡的数据集上,点击您想要创建的图表。
- 这将带您进入 Graph 编辑页面。
- 分配变量——填写每个字段时,图表预览会实时更新。
- 预览效果符合预期后,点击 "Continue"。
访问之前的制图文件
要开始自定义图表,请在 Graphing 页面顶部的 Graph 选项卡中选择您的图表。您也可以在此选项卡中访问同一数据集中的图表。
与其他数据集关联的之前创建的图表可以在您的 Gallery 中找到。
使用 BioRender AI(测试版)自定义图表
使用 BioRender AI(测试版)通过自然语言指令自定义图表。只需描述您想要进行的更改,例如更新颜色、标签、坐标轴或数据点样式,BioRender AI 就会为您应用这些更改。
使用 BioRender AI 自定义图表时,您的底层数据不会发生变化。您也可以随时继续手动编辑或撤销更改。
如需了解更多信息,请参阅使用 BioRender AI(测试版)自定义图表。
示例提示词:"对于所有活性大于 98% 或小于 2% 的数据点,将填充色设为红色"
示例提示词:"将所有数据点更改为菱形"
自定义选项
您可以自定义:
- 数据外观(颜色、边框、间距)
- X 轴和 Y 轴(刻度、标签、格式)
- 重新排列分类轴上的组
- 图例(位置、文本、间距)
- 标题和坐标轴标题(开关、字体、大小、颜色)
- 显示分析结果(显著性标记、p 值、括号、间距)
数据外观选项
- 点击 Graph 选项卡右上角的 "Customize graph"。
- 然后直接点击图表中您想要编辑的区域(例如数据)。这将打开数据外观 Options 菜单。
3. 在此菜单中,您可以:
- 更改调色板和边框颜色
- 调整边框宽度和圆角半径
- 修改组之间、组内以及图表边距的间距
坐标轴自定义
- 点击 X 轴或 Y 轴以打开坐标轴自定义菜单。
- 调整坐标轴线和标签格式。
- 对于连续(数值)坐标轴,您可以通过以下方式修改刻度:
- 手动输入最小值和最大值
- 使用加号/减号按钮进行增量调整
以下为 X 轴自定义示例
以下为 Y 轴自定义示例
重新排列分类轴上的组
您可以重新排列分类轴上的组,而无需重新排序底层数据集。
要重新排列组:
- 点击分类轴以打开坐标轴面板。
- 使用 Sort by 控件选择排序方式:
- Original - 保持默认顺序
- Alphabetical - 按字母顺序从 A 到 Z 或从 Z 到 A 排序
- By value (median) - 按中位数值升序或降序排序
- Custom - 打开拖放对话框以设置您自己的顺序
- 每个排序选项都包含升序/降序切换开关。
使用自定义顺序:
- 在对话框中拖动行以重新排序。
- 使用 Flip order 或 Reset order 进行快速调整。
- 每行还提供向上/向下按钮,支持键盘或单指针导航。
💡 注意:拖放重新排序仅适用于对话框内。您无法直接在图表上拖动组。在自定义顺序中间添加或删除分类可能会导致其他组的位置发生变化。在末尾添加和重命名是安全的。在对话框中快速重新拖动即可修复任何位置变化。
图例自定义
- 点击图例。
- 打开图例自定义菜单下拉列表,您可以:
- 调整位置(左、右、上、下)
- 更改文本方向和大小
- 修改间距
标题和坐标轴标题自定义
- 点击标题或任一坐标轴标题以打开自定义菜单。
- 您可以:
- 打开或关闭标题
- 设置文本样式
- 调整字体、大小、间距和颜色
如何显示分析结果
运行分析后,您可以在图表上显示分析结果。对于 ANOVAs,仅当选择了成对比较(例如 Tukey 检验)时才适用。
- 运行分析后,图表面板中会出现一个新部分,其中列出了您在此图表上运行的所有分析。
- 展开分析以查看所有成对对比。
- 默认情况下,系统会预先选中显著性比较,并自动将其显示在图表上。
- 勾选或取消勾选单个比较,以显示或隐藏这些比较,包括不显著的比较。
自定义分析结果的显示方式
点击图表上的任意显著性线或括号以打开外观菜单。在此处您可以:
- 在星号(∗)和 p 值显示之间切换
- 修改括号样式、字体和线条大小
- 调整间距和位置
💡 提示:您可以在同一图表上运行多个分析,并使用复选框控制显示哪些结果,这对于比较不同的检验方法非常有用。
如需详细了解如何运行分析,请参阅:执行统计分析
需要帮助? 请通过 support@biorender.com 联系我们的支持团队,或点击右下角的 "Chat With Us" 气泡开始在线聊天。